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1.0 Introduction  

1.1 SIMBA Program 

SIMBA is a program that simulates the highway bridge traffic load effect. It uses the traffic 

microsimulation Intelligent Diver Model (IDM) in this program. SIMBA is strongly characterised by 

road layout that has been configured by the user with the aid of several different road features that are 

available on the program. These layouts and features combine to create the desired situations and 

provide relevant analysis on each test. SIMBA allows the user to input several different types of road 

features such as bridges, obstacles, road gradient and speed limits as well as the politeness and bias 

parameters among others. Using these features, scenarios for specific sites can be reconstructed as to 

analyse the bridge loading effects during such period.  

Load effect calculations are performed for in-built or user-defined influence lines, and extensive 

output is given. The load effect calculation will be shown in the load effect chart and load effect 

dialog box in SIMBA program according to the in-built or user-defined influence lines (e.g.bending 

moment, compression, tension, etc). 

SIMBA was developed from EvolveTraffic, but has too many major changes to be considered ET v2.0. 

SIMBA was developed by Dr Colin Caprani.  

1.2 The User Manual 

Purpose 

This User Manual has been written to explain the use of the SIMBA program, and to explain its 

capabilities and limitation. It explains the user interface, the required input information, and the output 

information. 

Conventions 

Menus 

Menu commands are written as:  

 Configuration > Traffic Model (shortcut key: Alt+T) 
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Which mean the user should select Simulation from the Configuration menu as shown below:

 

Keyboard 

The use of shortcut keys is indicated as: 

Alt+T 

Which mean that user should press the “Alt” and “T” keys on keyboard simultaneously. 

Glossary 

IDM   intelligent Driver MODEL – the microsimulation model used in the current  

version of the program. 

Influence Lines (ILs) graphs the variation of a function (such as the shear felt in a structure 

   member) at a specific point on a beam or truss caused by a unit load placed 

   at any point along the structure. 

Load Effect  the result of a calculation using any influence line. Total load on the bridge  

is sometimes referred to as a load effect therefore. 

Output Detector  when a vehicle passes this form of detector, it is written to file along with its  

arrival time at the detector. Every road and direction must have these  

detectors. 

1.3 Release History 

SIMBA Program 

Version Date Description 
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1.4 Installing the Program 
SIMBA does not require installation, it will usually download as a zip file and extract into .exe 

application file which can be open directly. It has been tested on Windows XP, Vista and Windows 7. 

SIMBA can be run in both 64-bit version and 32-bit version. It is more efficient to run in 64-bit 

version as compare to 32-bit version. The program is a multi-threaded, single-process application and 

so cannot take advantage of multi-core processors. Thus for maximum speed, prefer a computer with 

a fast single processor over a computer with a multi-core slower processor.  

A computer with 1GB of RAM is sufficient and other programs can continue to operate successfully. 

SIMBA require traffic folder that generated from all kind of traffic file generator to operate 

successfully. The traffic file must be in notepad or text format (.txt). One of the traffic file generator is 

BTLS (BridgeTrafficLoadSim) developed by Colin Caprani.  

 

2.0 About SIMBA 

2.1 Introduction 

SIMBA allowed performing the following steps: 

1. An input traffic file containing a record of vehicles is opened and linked to Simulation 

Configuration. 

2. The simulation commences. 

3. Vehicles are read from the traffic file and enter the road at the time indicated in the traffic file. 

4. The vehicles proceed along the road with the several configurations that identify by users.  

5. When a vehicle arrives at an Output Detector identify by user, it is written to the output traffic 

file, with the time of arrival at the Output Detector. 
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6. The simulation progresses until all vehicles have been read from the traffic file and have 

exited the road.  

7. The result from simulation progresses will show in Load Effect chart. 

2.2 SIMBA: Capabilities and Limitations 

Capabilities 

SIMBA is able to: 

 Read data from CASTOR, SAFT or BeDIT traffic files format. 

 Manipulate vehicles according to the Intelligent Driver Model (IDM) traffic microsimulation 

model as they progress along a road. 

 Model roads of up to 20-lanes in width, 10 lanes per direction. 

 Consider 5 types of vehicle: cars, small truck, large truck, crane and low-loader. User-defined 

type of vehicle is allowed for user to define their ideal type of vehicle. 

 Consider type of vehicle in road feature configuration. 

 Take account of speed limit sections of road in both directions. 

 Take account of gradient sections of road in both directions. 

 Consider overlapping gradient and speed limit sections of road. 

 Take account of obstacles for lane-closure. 

 Output vehicles to file along with their arrival times at the output detector. 

 Output load effect on chart at the output detector. 

 

 

Limitations 

SIMBA is not able to: 

 Determine the number of lanes or directions of traffic in the specified input traffic file, in 

advance of the simulation. 

 Determine the input traffic files format (e.g.CASTOR, SAFT or BeDIT). 

 Model pedestrian walk path on bridge (if there is). 

 Model on-ramps or curves in the road. 

 Model different lengths of lanes or directions. 

 Further simulation if error occurred.  
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3.3 User Levels 

 

3.0 The SIMBA User Interface 

3.1 Introduction 

The SIMBA program has a Single Document Interface (SDI). This means only a single SIMBA file can 

be opened at any one time. The menu and toolbar commands, whilst being specific to the program, are 

operated in the same way as standard Windows programs. 

For user to make it much quicker and easier to use the program features during a simulation, there is 

extensive support for keyboard shortcuts in SIMBA. 

Overview of SIMBA: 

 

3.2 Menu 

At the top left of SIMBA program, a list of menu is shown as in the diagram below, and there are 

several user interfaces in each dropdown bar. The function is explained as below: 
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File > 

 New: 

Opens a new *.sba file with some default settings. 

 Open: 

Displays the Open File dialog for choosing an existing *sba file. 

 Save: 

Saves the current file. 

 Save As: 

Allows the current file to be saved as a different name, 

 Save Image: 

Saves the view currently visible to a *.bmp file specified in the Save dialog. This feature is useful for 

including configurations in reports/presentations etc. and avoid using the Windows Print Screen 

command. 

 Save Chart 

Saves the load effect chart to a*.bmp file specified in the Save dialog. 

 Print: 

Print the current view- this feature is not supported as may be seen from the Print Preview command. 
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 Print Preview: 

Displays a preview of the output that may be sent to the printer. 

 Print Setup: 

Specify the setup to be used when printing. 

 Recently Used Files: 

A list of files that used recently and it is for ease of access. 

 Exit: 

Close the SIMBA program. 

Configuration > 

 Simulation: 

Brings up the Simulation Configuration dialog box – see Section 4.2. 

 Traffic Model: 

Brings up the Traffic Model Configuration dialog box – see Section 4.3. 

 Road Features: 

Brings up the Road Features Configuration dialog box – see Section 4.4. 

 Metrics Detectors: 

Brings up the Metrics Detectors Configuration dialog box – see Section 4.5. 

 Discrete Distribution: 

Brings up the Discrete Distribution Configuration dialog box – see Section 4.6. 

 Vehicle Types: 

Brings up the Simulation Configuration dialog box – see Section 4.7. 

 Bridge: 

Brings up the Bridge Configuration dialog box – see Section 4.8. 

 Influence Lines: 
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Brings up the Influence Lines Configuration dialog box – see Section 4.9. 

 Add Simulation Element: 

Brings up the Add Simulation Element Configuration dialog box – see Section 4.10. 

Run > 

 As Visible: 

Run the simulation showing the animation on screen- see Section 5.2. If the simulation is currently 

paused, this restarts the simulation as per Tools > Pause (Resume) 

 A Single Step: 

Progress the simulation by a single step at each time user press on it– see Section 5.2. 

 A Invisible: 

Run the simulation in a background process- see Section 5.2. 

Tools > 

 Zoom In: 

Zoom into the roads; enlarge the road and vehicles on the screen. 

 Zoom Out: 

Zoom out from the road, making road and vehicles smaller on screen. 

 Speed Up: 

Accelerate the simulation- the ratio of simulation time to real time increases. Maximum time warp 

factor is ×15. 

 Slow Down: 

Decelerate the simulation- the ratio of simulation time to real time decreases. 

 Resume (Pause): 

Once the simulation is running, it can be pause and resume. If the simulation is paused, this command 

changes to Resume, and resumes the simulation when clicked. 

 Stop: 
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Stops the current simulation. 

 Mute Detectors: 

Turns on or off all detector output for the next simulation. 

 Mute Bridges: 

Turns on or off all the bridges existed on screen for the next simulation. 

 View Preferences: 

Displays the Preferences dialog – see Section 5.3. 

 Show Program Settings: 

Hide or unhide the Program Settings dialog box – see Section 3.5. 

 Reset Program Settings: 

Reset the program settings back to default settings. 

View > 

 Standard: 

Hide or unhide toolbar. 

 Simulation Elements: 

Hide or unhide Simulation Elements dialog box. 

 Properties: 

Hide or unhide Properties dialog box. 

 Program Settings: 

Hide or unhide Program Settings dialog box. 

 Validation: 

Hide or unhide Validation dialog box. 

 Vehicle: 

Hide or unhide Vehicle dialog box. 
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 Load Effect Chart: 

Hide or unhide Load Effect Chart. 

 Diagnostics: 

Hide or unhide Diagnostics dialog box. 

 Load Effects: 

Hide or unhide Load Effects. 

 Legend: 

Hide or unhide Legend. 

 Customize: 

Allow user to customize the Commands, Toolbars, Keyboard, Menu and Options.  

Window >  

Users allow rearranged the view of artificial model or opened a new window. 

Help > 

 About: 

This shows information about the copyright/developers and version of the program running. 

 

3.3 Toolbar Menu 

 

 

Each of the buttons indicated provide a shortcut that used often. The menu commands as follows: 

1- File > New 

2- File > Open 

3- File > Save 

4- File > Print 

5- Configuration > Simulation 
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6- Configuration > Traffic Model 

7- Configuration > Vehicle Type 

8- Configuration > Road Features 

9- Configuration > Metrics Detector 

10-  Configuration > Bridges 

11-  Configuration > Influence Lines 

12-  Configuration > Discrete Distributions 

13-  Run > As Visible 

14-  Tools > Resume (Pause) 

15-  Tools > Stop 

16-  Run > As Invisible 

17-  Run > A Single Step 

18-  Tools > Zoom In 

19-  Tools > Zoom Out 

20-  Tools > Speed Up 

21-  Tools > Slow Down 

22-  Tools > Mute Detectors 

23-  Tools > Mute Bridges 

24-  Tools > View Preferences 

25-  Help > About  

 

3.4 Shortcut Keys 

Shortcut keys are available in SIMBA. There are certain commands are only accessible through the 

keyboard and mouse (only apply to the layout). 

Commands only accessibly through the keyboard: 

 Left Arrow: Moves the viewport to the left. 

 Right Arrow: Moves the viewport to the right. 

 Home: Moves the viewport to the start of the road (left end). 

 End: Moves the viewport to the end of the road (right end). 

Commands only accessibly through the mouse:  

 Wheel (up): Moves the viewport upwards. 

 Wheel (down): Moves the viewport downwards. 

 Ctrl + Wheel (up): Zoom in. 
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 Ctrl + Wheel (down): Zoom out.  

Keyboard shortcuts that give menu commands: 

 Ctrl + N: File > New 

 Ctrl + O: File > Open 

 Ctrl + S: File > Save 

 Ctrl + I: File > Save Image 

 Ctrl + P: File > Print 

 Alt + S: Configuration > Simulation 

 Alt + T: Configuration > Traffic Model 

 Alt + R: Configuration > Road Features 

 Alt + M: Configuration > Metrics Detectors 

 Alt + D: Configuration > Discrete Distributions 

 Alt + V: Configuration > Vehicle Types 

 Alt + B: Configuration > Bridge 

 Alt + I: Configuration > Influence Lines > Define ILs 

 Shift + Alt + I: Configuration > Influence Lines > Import IL File 

 F5: Run > As Visible 

 F4: Run > A Single Step 

 Shift + F5: Run > As Invisible 

 F10: Tools > Zoom In 

 F11: Tools > Zoom Out 

 F6: Tools > Speed Up 

 F7: Tools > Slow Down 

 F9: Tools > Pause 

 F12: Tools > Stop 

 Ctrl + M: Tools > Mute Detectors 

 Ctrl + B: Tools > Mute Bridges 

 Alt + P: Tools > View Preferences 

3.5 Other Interface  

Apart from shortcut keys and menu commands, SIMBA contain several dialog box in which the user is 

prompted to provide information or select commands. The dialog box is a small area on screen in 

SIMBA.  

Simulation Elements 
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Simulation Elements is input data that user required to input and it is generally obtain from the menu 

commands (configuration). Instead of using menu commands, user can select commands directly from 

the dialog box as shown below:  

 

Note that IDM Parameters refer to Configuration > Traffic Model in menu commands. 

Properties 

In the Properties dialog box, the dropdown box contained two different features: Simulation Elements 

& Window Properties. Simulation Elements is an input data where users required to define the bridge 

and influence lines in road model. The Window Properties used to handle the properties of the SIMBA 

program (e.g. scales, dimensions, borders, etc). Example of Properties dialog box is shown below: 

 

The relevant information about the Simulation Elements is listed as follow: 
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 General > Element Type 

The type of the simulation element currently selected. 

 General > ID 

The index of the load effect for its bridge. 

 General > Description 

Use a meaningful description for this simulation element. 

 Influence Line > IL Type 

Select an influence line type: either a built-in function or a user-specified discrete influence line. 

 Influence Line > Discrete 

Choose the discrete influence line. 

 Lane Weights > Index [1] 

The weight for the lane of this index. 

The relevant information about the Window Properties is listed as follow: 

 Scales > Overall scale 

Set the overall scale of the road drawing. 

 Scales > Width scale 

Set the scale of the exaggerated widths. 

 Scales > Vehicle length scale 

Set the scale of the exaggerated vehicle lengths. 

 Dimensions > Lane width (m) 

Set the road lane width (m). 

 Dimensions > Vehicle width (m) 

Set the vehicle width (m). 

 Dimensions > Tick length (m) 



SIMBA (v1.5.2.0)  User Manual 

 

Colin Caprani Page 18 
 

Set the tick length for the road ruler (m). 

 Dimensions > Tick interval (m) 

Set the tick interval for the road ruler (m). 

 Options > Show velocities 

Show the velocities on the top of each vehicle, or not. 

 Options > Show legend 

Show the legend in the view window, or not. 

 Borders > Top (m) 

Set the border for the top of the view. 

 Borders > Bottom (m) 

Set the border for the bottom of the view. 

 Borders > Left (m) 

Set the border for the left hand side of the view. 

 Borders > Right (m) 

Set the border for the right hand side of the view. 

Clocks 

In both Visible and Invisible Modes of simulations, two clocks are shown in the viewport: 

 A simulation clock: represents time as observed by the vehicles. 

 A real clock: represents the elapsed actual time since the start of the simulation. 
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In Visible Mode, when paused, the real clock is also paused. This means that at the end of the 

simulation an estimate of the average time warp (ratio of simulation to real time) is easily obtain. 

In Invisible Mode, only the final simulation and real times are shown upon completion of the 

simulation. This enables the time warp to be calculated. 

Calculation of the time warp can prove useful to examine the effect of including various detector 

output, or even just the detector’s time intervals. The maximum time warp factor is ×1000 and 

information about time warp factors can be found in Diagnostics dialog box. 

Diagnostics 

The diagnostics gives an indication of the amount of simulation complete and remaining as well as the 

time warp factors. At the start of the simulation, SIMBA counts the number of vehicles in the input 

traffic file. At each time step the number of vehicles already read from the file is compared to the total 

number of vehicles to give percentage vehicles on, as shown: 

 

Note that once the last vehicle has entered the road the commands will display 100% (since all 

vehicles have been read), but the simulation is not complete until the last vehicle has left the road. The 

diagnostics records time and date of the simulation.  

Validation 
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Validation helps to check that the input data satisfies or fits the intended uses in order to run 

simulation without any crash or error. If warning shows in the validation dialog box, user required to 

modify the input data to avoid further error to occur.  

Vehicle DataTips 

All the relevant information about a vehicle can be obtain through the Vehicle DataTips. 

To obtain relevant information on a vehicle: 

1. The simulation must be run in Visible Mode. 

2. The simulation must be paused. 

3. Left click on the vehicle of interest on screen and the information about the vehicle will 

displays in Vehicle DataTips. 

4. The Vehicle DataTips contain all the relevant data for the selected vehicle is shown as follow: 

 

Program Settings 

All relevant general settings on road model are listed in Program Settings. It is included Intelligent 

Driver Model (IDM), road, time and view. The Program Settings come with default setting and users 

are allowed to change the settings and the view of road model in viewport. The Program Settings in 

SIMBA as shown below: 
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The information in Program Settings is given below: 

 General > File buffer size (MB) 

The size of the RAM allocation buffer for every output file. Make this as large as your RAM will 

allow to minimize hard drive access during simulations to minimize time delays. Balance this value, 

the number of output files and your machine’s RAM. 

 IDM > Min space for next vehicle (m) 

The minimum clear space in front of the next vehicle to enter the road, before it is allowed onto the 

road. 

 IDM > Safe braking (m/s2) 

The maximum permissible deceleration any vehicle can undergo. This number provides a check on 

the realism of the random braking ability generated according to the user-defined IDM parameters. 

 IDM > Desired gap model 

The model for s*of the IDM, used when the speed difference between the lead and following car is 

negative (lead faster). 
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 IDM > Lane change min. gap (m) 

The minimum gap to the rear of the vehicle in front, in the target lane, or from the front of the rear 

vehicle in the target lane, to the rear of the current vehicle. A lane change is not considered if both 

these gaps are not larger than this parameter specifies. 

 IDM > Lane change time delay (s) 

This specifies th time gap between consideration of lane change events for a particular vehicle. Once a 

lane change event has occurred for this vehicle, the timer is reset and a subsequent lane change can 

only occur once the specified time delay has been passed. 

 IDM > Lane change follower 

This specifies whether the advantage to the current following vehicle will be considered in deciding a 

lane change. 

 IDM > Lane change fast lane follower 

If LC_FOLLOWER is true, this restricts its application to outside lanes only. Consideration of lane 

change for vehicles in the inside lane is not influenced by follower advantage if this is set to true. 

 Road > Road end buffer (m) 

This is the distance that the front vehicle in any lane considers as being clear road (no vehicles) in 

front of them, even as it approaches the end of the defined road length. This means that vehicles 

approach the end of the road realistically. 

 Road > Bridge on buffer (m) 

A vehicle is considered for influence line calculations when within this buffer distance of the start or 

end of the bridge. This helps avoid calculation inaccuracies for load effects sensitive to when the 

vehicle arrives on the bridge due to the distance moved in the time step. 

 Road > Gradient > Maximum slope (%) 

This is the maximum permissible slope of gradient that the user can specify. Included to keep things 

more realistic, and to conform better with the assumptions made in modifying the vehicles’ driver 

model. 

 Road > Gradient > IDM Modifiers > A flag 
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This flag specifies if vehicles acceleration ability is to be modified to account for the gradient it is on. 

Included because Treiber does not do this, ut basic physic suggests that vehicles acceleration ability is 

lessened. This ability is not modified for downhill gradients. 

 Road > Gradient > IDM Modifiers > A min 

The minimum acceleration ability that any vehicle can have after having its ability modified to take 

account of a gradient it may be on. This number must be greater than zero. The program will crash 

due to a divide by zero, or a square root of a negative number if it is not. 

 Road > Gradient > IDM Modifiers > B flag 

This flag specifies if a vehicle braking ability is to be modified to account for the gradient it is on. 

Included because Treiber does not do this, but basic physics suggests that a vehicle can brake easier 

going uphill. This ability is not modified for downhill gradients.  

 Road > Gradient > IDM Modifiers > T slope (%/s) 

This specifies how the IDM parameter, T, the safe time headway, changes according to the gradient 

the vehicle is on. This value is the number of percent of gradient, per second increase in the safe time 

headway. It is increased for the gradient, whether uphill or downhill. 

 Road > Gradient > IDM Modifiers > V0 min 

This specifies the minimum desired velocity any vehicle can have after its desired velocity has been 

modified to account for the gradient the vehicle is on. This number must be greater than zero, since 

every vehicle should want to make progress. 

 Road > Gradient > IDM Modifiers > V0 slope (%/km/h) 

This specifies how the IDM parameter, V0, the desired velocity, varies with gradient.it is measured in 

the % gradient per 1km/h reduction in the desired velocity. The desired velocity is reduced for 

downhill gradients and not modified for uphill gradients. 

 Road > Gradient > Speed limit > Max. (km/h) 

This is the maximum permissible speed limit that the user can specify. Included to keep things more 

realistic. 

 Road > Gradient > Speed limit > Min. (km/h) 

This is the minimum permissible speed limit that the user can specify. Included to keep things more 

realistic. This must be greater than zero. 
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 Time > Days per simulation month 

Since we usually consider there to be 5 working days per week for 50 weeks per year – which allows 

for holidays – we have 250 days per year. We thus consider there to be 0 working “months” per year 

of 25 workings “days” each. A vehicle with a time stamp of 3500000 seconds thus is written out to 

file as: 10/02/08 12:13:20. 

 Time > Months per simulation year 

Since we usually consider there to be 5 working days per week for 50 weeks per year – which allows 

for holidays – we have 250 days per year. We thus consider there to be 0 working “months” per year 

of 25 workings “days” each. A vehicle with a time stamp of 3500000 seconds thus is written out to 

file as: 10/02/08 12:13:20. 

 View > Min. view scale 

The minimum value the user can zoom out to. Setting this value too low will result in the program 

crashing. 

 View > Data tip delay (s) 

The time in seconds that the vehicle datatip stays visible after the user clicks on a vehicle in pause 

mode. Must be greater than zero or program will crash. 

 View > Timewarp Sim. Step (ms) 

The time in milliseconds (simulation timestep divided by the timewarp) that if the delay between 

simulation steps is less than, the accelerated timewarp is used. This only applies in visible mode. 

Higher values of this will cause the vehicles to appear jumpy on screen at lower timewarps. 

 View > Timewarp step 

The step in the timewarp factor when the user selects Speed Up or Slow Down. The simulation must 

be run in visible mode. 

 View > Zoom step 

The step in the zoom factor when the user selects Zoom In or Zoom Out. The simulation must be run 

in visible mode. 

 View > Wide pen width (pixels) 

Set the width of the wide pen (used for certain elements such as detector ends, etc.) in pixels. 
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 View > Thin pen width (pixels) 

Set the width of the thin pen (used for certain elements such as road lines, etc.) in pixels. 

 View > Colours > Background 

The display colour for the background – usually white. 

 View > Colours > Road surface 

The display colour for the road surface. 

 View > Colours > Bridge surface 

The display colour for the bridge surface. 

 View > Colours > Road lines 

The display colour for the road line markings. 

 View > Colours > Ruler lines 

The display colour for the ruler tick lines. 

 View > Colours > Ruler text 

The display colour for the ruler text. 

 View > Colours > Legend text 

The display colour for the legend text. 

 View > Colours > Vehicle highlight 

The display colour for the box highlighting the selected vehicle. 

 View > Colours > Output detector 

The display colour for the output detectors. 

 View > Colours > Flow density detector 

The display colour for the flow density detectors. 

 View > Colours > Headway detector 

The display colour for the headway detectors. 
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 View > Colours > Composition detector 

The display colour for the traffic composition detectors. 

 View > Colours > Macro-stats detector 

The display colour for the macroscopic statistics detectors. 

 View > Colours > Micro-stats detector 

The display colour for the microscopic statistics detectors. 

 View > Colours > Occupancy detector 

The display colour for the occupancy detectors. 

 View > Colours > Space- Time SMS detector 

The display colour for the space-time space-mean-speed detectors. 

 View > Colours > Space- Time density detector 

The display colour for the space-time density detectors. 

 View > Colours > Speedlimit feature 

The display colour for the speed limit feature regions. 

 View > Colours > Gradient feature 

The display colour for the gradient feature regions. 

 View > Colours > Obstacle feature 

The display colour for the obstacle feature regions. 

 View > Colours > Politeness feature 

The display colour for the politeness feature regions. 

 View > Colours > Bias feature 

The display colour for the bias feature regions. 

 View > Colours > Gap feature 

The display colour for the gap control feature regions. 
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 View > Legend > Det.line length (px) 

The detector line length for the legend 

 View > Legend > Vehicle height (px) 

The vehicle box height for the legend 

 View > Legend > Vehicle width (px) 

The vehicle box width for the legend. 

 View > Legend > Det.height (px) 

The segment feature or detector box height for the legend. 

 View > Legend > Det.width (px) 

The segment feature or detector box width for the legend. 

 View > Legend > Text distance (px) 

The symbol to text distance for the legend. 

4.0 SIMBA Input 

 

4.1 Introduction 

As mention earlier, SIMBA is a micro-simulation program that aims at simulating traffic over a given 

period. SIMBA attempts to incorporate human interaction and patterns as input to allow the analysis of 

traffic flow and loading across the bridge. The output data from SIMBA is only of use if the input 

data is representative of the traffic stream of interest. Different layout encourage to be design with the 

aid of different input data and configuration. With different design layout, the user can then compared 

to measured traffic statistics and macroscopic properties. This program is therefore an iterative 

process and simulation might take several iterations to obtain detail output data. 

To minimise effort, all the input data for the program can be saved into SIMBA files – file of type 

*.sba. Different road layout and road configuration can be saved in different *.sba file. 

In SIMBA, different types of input that user might look into are listed as below: 

1. Traffic files: The files that generated from traffic file generator such as BTLS. 

2. Configuration files: The main user input file which configures each run of the program. 
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3. Properties: Location where main user define bridges coordinate and influence lines that used 

in the simulation.  

During the simulation, the traffic files and properties used by user might be the same data, there will 

be several change in configuration files (e.g. lengths, speed limits, obstacle, etc) that can result in 

(slightly) different traffic output files and load effect on bridges that defined by user.  

Warnings will be given in Validation dialog box if there is some missing input data.  

 

4.2 Simulation Configuration 

This dialog configures the traffic file details, road details, simulation details and output directory 

which belong to simulation parameters. Different input details that user required to define in 

Simulation Configuration as shown in the diagram below are explained as follows: 

 

Traffic File Details 

 Input Traffic File: The file from which the traffic to be placed on the road is read. 

 Traffic File Format: The format of the file to be read in and written out. 

o CASTOR: Supports multiple-lane traffic. 

o SAFT: Format for single lane traffic. 

o BeDIT: an extended version of the CASTOR format. 

 Number of lanes: Specify the number of lanes of traffic in each direction, as contained in the 

traffic file. 

*Note: SIMBA does not check the file format prior to reading the file. Therefore setting the wrong file 

format here will result in a program crash.  
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*Note: SIMBA does not check the number of lanes in the traffic file prior to reading the file. Therefore 

setting the wrong number of lanes may result in a program crash. In particular: 

- Define more lanes than there are on traffic file does not cause crash and affect the program. 

- Define fewer lanes than there are on traffic file results in a program crash. 

Output Directory 

 Specify directory: The output file generate at clearly defined directory by user as the traffic 

passes the output detector. The rest of metrics file will be delete when user run the simulation 

on particular road model. 

 Auto-generate directory (recommended): The output file generate at default directory as the 

traffic passes the output detector.  

 Metrics Directory: The directory to which the metrics detectors output files (if any) will be 

written.  

Simulation Road Details 

 Road Length: The length of the road in metres that the vehicles are to be driven along. All 

lanes are this length. 

 Drive on the: Choose the drive-side for the vehicles, European or British-Irish. This setting 

only affects the graphical display of the road and vehicles. 

 Lane Changes Allowed: Choose whether to allow lane changes or not. 

 Output Cars to File: Specifies whether or not cars are to be output to output traffic file. This is 

useful for creating truck-only traffic files which are of chief interest in bridge loading 

calculations. 

 Number of Lanes: Specify the number of lanes in each direction in positive x-direction or 

negative x-direction. Positive x-direction indicate the vehicle flow from left to right in 

viewport, while negative x-direction indicate the vehicle flow from right to left in viewport.  

If there is only one direction choose 0 lanes for the Direction 2 (choosing zero lanes for 

Direction 1 means the program will swap Direction 1 and Direction 2- single direction roads 

always run in the positive x-direction).  

*Note: User cannot set fewer lanes in the simulation road than there are in the input traffic file 

since the vehicles cannot arrive to non-existent lanes and may result to program crash. 

Simulation Details 
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 Simulation Time Step: The time step, in milliseconds, that the simulation progresses 

against. Vehicle driving properties are only updated once per time step. If the time step is 

too small will result in inefficient, while time step is too large will result in inaccuracies. 

Hence for the IDM, Treiber uses 250 ms typically and it is highly recommended to use 

250 ms to run simulation. 

 Execute on open: It is on/off button where user can choose to or not to execute the 

simulation once the *.sba files is open. Note that it is recommended to untick the button. 

 

4.3 Traffic Model Configuration 

This dialog configures the Intelligent Driver Model (IDM) parameters that influence driving 

behaviour. IDM is a time-continuous car-following model for the simulation of traffic on roads. Up to 

6 different types of vehicle contain different driving behaviour and each of them can be define by user 

in this program. Several parts in Traffic Model Configuration are clarify as follow with attached 

diagram below: 

 

 

IDM Parameters for Vehicle Type 

The program considers 6 vehicle types in the dropdown box: 

 Type 1 – Cars: any vehicle under 3.5 tonnes 

 Type 2 – Small Trucks: any vehicle with less than 4 axles (e.g. 2- and 3-axle vehicles) over 

3.5 tonnes. 
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 Type 3 – Large Trucks: any vehicle that is not a car, small truck, crane or low-loader. 

 Type 4 – Crane: any vehicle that is not a car and has a maximum axle spacing of 4.5m and an 

average axle spacing less than 2.5m. 

 Type 5 – Low-loader: any vehicle that is not a car and has a maximum axle spacing not less 

than 7.5m. 

 Type 6 – User-Defined Vehicle: a general vehicle type allowing user to isolate particular 

vehicles of interest. This type takes precedence over all other vehicle types, so care must be 

taken that all vehicles are not assigned to this type, unless user intended to use this vehicle 

type. 

IDM Parameter Set 

 Safe time headway, T (s): the safe time headway to the vehicle in front (tip of one vehicle to 

the top of the next vehicle behind). 

 Maximum acceleration, a (m/s^2): The maximum limit of rate of change of velocity. 

 Comfortable deceleration, b (m/s^2): “Comfortable” braking deceleration in every traffic. 

 Minimum jam distance, s0 (m): Minimum bumper-to-bumper distance to the front vehicle. 

 Elastic jam distance, s1 (m): Elastic bumper-to-bumper distance to the front vehicle. 

 Desired velocity, v0 (km/h): Desired speed when driving on a free road. 

 Acceleration exponent, delta: The increase rate of change of velocity in the rate of exponent. 

 Lane change politeness factor, p: Factor takes into account the advantages and siadvantages 

of other drivers associated with a lane change. 

 Outside lane bias factor, deltaAbias: Factor of keep-right directive of the lane usage rule. 

 Lane change threshold, deltaAth (m/s^2): Threshold of keep-right directive of the lane usage 

rule. 

*Note: For more details explanation on the IDM parameters, it is useful refers to (Treiber,M., 

Hennecke., and Heibing,D., 2000)[1] and (Kesting,A.,Treiber,M.,Helbing,D., 2007)[2]. In Treiber’s 

work, all the parameters had the same value of each vehicle type he considers. 

 

Distribution 

SIMBA allowing vehicles within a type to have varying parameters, that is, the program allows 

probabilistic parameters. The program retains the ability to specify deterministic (or constant) 

parameter values.  
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Each parameter can be distributed according to a number of distributions. It is up to the user to decide 

upon the distribution that best suits the parameter being modelled. The program disables cells not 

requiring data for the chosen distribution. The supported distributions, with required parameters and 

some comments are: 

1. Normal: Location and Scale – the standard Gaussian distribution of parameters mean and 

standard deviation. 

2. Constant: Location – this is the deterministic option as no random numbers are generated and 

the parameter takes the value location for all vehicles in the type. 

3. Discrete: The user chooses a pre-defined discrete distribution from the presented dropdown 

box. 

4. Uniform: Location and scale: location is the middle of the uniform distribution PDF, and the 

scale is the half-width of the rectangular PDF (or range of the data). 

5. GEV: Location, Scale and Shape parameters – although strictly an extreme value distribution, 

its flexibility (due to its three parameters) allows many phenomena to be modelled accurately. 

6. Gumbel: Location and Scale parameters. 

7. Poisson: Location and Scale parameters – provides a continuous approximation to the discrete 

distribution only valid when the location parameter is greater than 10. 

8. Log-Normal: Location and Scale parameters. 

9. Exponential: Location and Scale parameters – may be useful for some parameters such as 

Safe Time Headway. Not suitable for most parameters, for example, Desired Velocity. 

10. Gamma: Location and Scale parameters. 

*Note: SIMBA does not check the validity of the distribution values entered, save for ensuring 

positive values. It is up to the user to verify that the values and distribution chosen are realistic and 

appropriate both to the distribution and the parameter. Choosing inappropriate values or distributions 

will result in program crash. 

For calibration purposes it is recommended to use Constant parameters initially and then use 

appropriate distributions with increasing values of Scale. This allows the impact of the probabilistic 

parameter values to be assessed. In any case, since most parameters cannot be directly measured, the 

Scale or Shape parameters must be based upon judgement and the effect upon the macroscopic traffic 

statistics. 

Defining a Parameter Set 

Choose the Vehicle Type from the drop-down box labelled IDM Parameters for Vehicle Type. There 

are two methods of entering data: 
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1. Using the mouse single click the left button on the cell under “Location/Name”, “Scale” and 

“Shape” cell or double click the left button to the dropdown box under “Distribution” cell. 

2. Use the Tab and arrow buttons to move between cells.  

 Under “Distribution” appropriate cell is selected, use arrow button to select the 

specified distribution. 

 Under “Location/Name”, “Scale” and “Shape” appropriate cell is selected, typing a 

value places that value in the cell.  

Copying Parameter Sets Between Vehicle Types 

Since it is likely that most parameter values will be the same between types, the dialog allows the user 

to copy parameters sets between vehicle types. For example, to copy the parameter set from vehicle 

Type 3- Large Truck to Type 2- Small Truck: 

1. Be currently defining parameters for vehicle Type 2- Small Truck vehicle by choosing the 

Vehicle Type from the drop-down box labelled IDM Parameters for Vehicle Type. 

2. In the second (right) drop-down box, select Type 3- Large Truck. 

3. Press the “<< Copy From <<” button, where the arrows indicate the direction in which the 

copying parameter sets from Type 2- Small Truck to Type 3- Large Truck. 

4.4 Road Features Configuration 

This dialog configures the road features, user allow to define the road features such as speed limit, 

gradient, lane obstacle, etc. There are up to 7 features that user allow to define and it is shown as 

follows with detail explanation as below: 

 

Adding and Deleting Road Features 
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To add a Road Feature row, press the Add Feature button and then edit the details of the newly 

added feature named Feature number x. To delete a Road Feature row, select the appropriate number, 

x from the dropdown list and press the Delete Feature No. button.  

Type of Road Features 

User allow to mouse double-click the left button on the cell under “Type” to open the dropdown box 

and select type of features on road. Each road features are listed as below: 

 Speed Limit: The maximum speed at which road vehicles may legally travel on selected 

region along the road with limit of vehicle speed. 

 Gradient: Also called slope, incline or decline of road that refers to the tangent of the angle 

of that surface to the horizontal.   

 Obstacle: Something that stands in the way of or holds up the progress and cause the lane 

closure. Usually apply to rehabilitation work on road. 

 Politeness: The factor of equation that govern the behaviour of driver. 

 Bias: Selected lane where most of the vehicle concentrated on and follow the vehicle in front. 

Overtaking or lane change is allowed for driver to move forward. 

 Lane Change Ban: Driver are prohibit to change lane in the selected region of road. No 

overtaking allowed. 

 Gap Control: The gap distance between vehicles. Its measure from back of vehicle to front 

of another vehicle.   

Direction 

There are two different direction given in dropdown box under “Direction” cell:  

 Positive x: Vehicle move from left to right in road viewport model. 

 Negative x: Vehicle move from right to left in road viewport model. 

Vehicle Types 

User allow to select different type of vehicle in the dropdown box under “Vehicle Types” cell and 

define different road features configuration on it. In Road Features Configuration, the vehicle types 

that user allow to select are listed as below: 

 All Vehicles 

 All Trucks 

 Cars 

 Small Trucks 
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 Large Trucks 

 Cranes 

 Low-loaders 

 User-defined 

Refer to Section 4.3 for an explanation of the vehicle types considered by the program. 

Adherence 

User allow to key in the value in the “Adherence” cell. The value allow to put into the cell ranged 

from 0 to 1. Adherence refer to percentage of driver on road that obey and disobey the rules on the 

lane that defined by user. The type of road features that require value of adherence is speed limit, 

obstacle, politeness, bias, lane change ban and gap control. 

For example, when the speed limit is set by user in selected region with adherence value is 0.9. This 

mean that 90% of driver obey the speed limit and 10% of driver speeding which disobey the speed 

limit defined by user.   

Start (m) / End (m) 

SIMBA allow user to input road features at certain coordinate and region along road model. The road 

features will be apply to the region from start (m) to end (m) define by user. The values must be in 

meters. (e.g. At starting point of 200m to end point of 500m, speed limit of 60km/h is apply to the 

region. This mean that along the 300m in between 200m and 500m, user only allow to drive at 

maximum speed of 60km/h.) The start (m) and end (m) has been clarify as follows: 

 Start (m): The coordinate at the beginning, start from the left side of viewport. 

 End (m): The coordinate at the finish point, located at the right side from start of viewport. 

Value/Lane 

Different road features consist of either value or lanes that user can define in cell under “Value/Lane”, 

there are listed as below: 

 Speed Limit: 

Type the “Value” of the speed limit; that is, the actual speed limit in km/h. though up to two 

decimal places is allowed, this is only enabled for defining gradients – speed limits should be 

integer valued. Non-integer speed limits will be rounded by the program. 

  

*Note: User must be caution and prevent defining overlapping speed limit sections as SIMBA 

cannot identify the overlaps of speed limit. Apart from that, SIMBA wasn’t able to prevent 
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unrealistic speed limits such as 200km/h speed limits. The recommended speed limits that 

user should defined is between 10 and 150km/h. 

o Effect of Speed Limit on a Vehicle 

When a vehicle enters a speed limit region the program carries out the following steps: 

1. Checks to see if the speed limit is less than the vehicle’s desired velocity, if fulfil 

the criteria proceeds to the next step. 

2. Stores the desired velocity of the vehicle before it entered the speed limit region. 

3. Sets the vehicle a new desired velocity as follows: 

a. If the distribution of desired velocity of the particular vehicle type is 

discrete, then the new desired velocity is the speed limit.  

b. Otherwise, the ratio of desired velocity to speed limit is kept the same as 

the initial desired velocity to average desired velocity (e.g. the location 

value of the IDM V0 distribution). 

This last step means that vehicles going faster than the average for their type remain 

faster when in the speed limit region and similarly for slower vehicles. This only 

applies to non-discrete distributions, as intermediate values of discrete distributions 

are not possible. 

When a vehicle leaves a speed limit region of road, its initial desired velocity is 

restored. Note that a vehicle can enter multiple speed limit regions and still have its 

initial desired velocity restored. 

 Gradient: 

To specify a section of road with gradient, follow the steps as per the Speed Limit Road 

Feature. The “Value” of a Gradient Road Feature is the slope of the road, measured as a 

percentage: 

 

*Note: SIMBA doesn’t checks the overlapping gradient sections of road. The recommended 

maximum slope is 15%. 

 Obstacle:  
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Type the “Lane” number of the obstacle or number of lane closures; the lane number is local 

to the direction, and measured from the outside lane (the driving lane, not the overtaking lane). 

 

*Note: Total road closures are checked and the user prevented from defining these. In doing 

so, adjacent lane closures have an extra buffer of 10m added to recognize the space required 

for vehicles to change lane. 

 Politeness: 

Type the “Value” number to define the behaviour of driver. It is scaled from -1 to +1. -1 

shows polite driving behaviour while +1 shows aggressive driving behaviour.  

 

 Bias: 

Type the “Lane” number to define the number of lane where most vehicle concentrated on the 

road model and lane that allow overtaking.  

 Lane Change Ban: 

Type the “Lane” number to define the number of lane where overtaking is not allow for 

vehicles in positive x or y direction. 

 Gap Control: 

Type the “Value” of the distance gap control between vehicles while in selected section in 

road model. 

 

4.5 Macroscopic Traffic Flow Metrics Detectors  

This dialog allows user to define locations on the road where information regarding the traffic flow is 

abstracted: 
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The Macroscopic Traffic Flow Metrics Detectors is important as it give output data in excel file 

format at the end of the simulation according to the detector defined by user. 

To add a detector, select the “Add Detector” button. To delete a detector, select the detector number 

in the list and click “Delete Detector No.” button. Both the buttons located at the bottom right at the 

dialog. For all types of detector the following parameters are the same: 

 Type – the type of detector. 

 Direction – the road direction the detector covers. 

 Vehicle Types – the types of vehicles that the detector examines. 

*Note: Detector location definitions (Parameters A and B) must be made in global road coordinates, 

not local direction coordinates. 

The types of detectors available are describe as following: 

 Flow & Density: Flow and density at a point detector. Density is estimated using harmonic 

estimate of space mean speed. 

 Headway: The time distance between successive vehicles. 

 Composition: The composition of the traffic detected by vehicle type. 

 Lane Changes: An over-arching detector of lane changes. 

 Output Vehicles: The output of vehicles at the detector for further analysis. 

 Macro Segment: A segment of road recording macroscopic statistics.  

 Micro Segment: A segment of road recording microscopic statistics. 

 S-T Density: An array of detectors to output space-time-density information. 

 S-T SMS: An array of detectors to output space-time-space mean speed information.  
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 Occupancy: The percentage of time a segment of road is occupied by vehicles. 

The guide for user to use parameters for different detectors are tabulated as follows: 

Detector Type Parameter A Parameter B Parameter C 

Flow & Density Location - - 

Headway Location - - 

Composition Location - - 

Lane Changes Interval - - 

Output Vehicles Location - - 

Macro Segment Start End - 

Micro Segment Start End - 

S-T Density Start Interval End 

S-T SMS Start Interval End 

Occupancy Start End - 

*Note: “-” dashed line means that user doesn’t require to input values into the cells.  

Flow & Density 

This detector extracts the flow and density of the traffic as follows: 

 The flow is determined by counting the number of vehicles (of the selected type) passing 

during the time interval. This figure is then changed to the standard vehicles per hour measure. 

 The density is determined from the flow per hour (previously found) divided by the average 

velocity of the vehicles during the time interval. That is, SIMBA uses the relation: 

𝐹𝑙𝑜𝑤 = 𝐴𝑣𝑒𝑟𝑎𝑔𝑒 𝑉𝑒𝑙𝑜𝑐𝑖𝑡𝑦 × 𝐷𝑒𝑛𝑠𝑖𝑡𝑦 

The time interval directly affects the calculation of the above properties, and so is of important in the 

results. Thus, the parameters are: 

 Time Interval – the interval (in simulation time) between the detector outputs. 

 Parameter A – this value specifies the location of the detector. 

Refer to Section 6.3 for information on the data output by Flow & Density detector. 

Headway 

This detector gather the headway data as output for the selected vehicle types. 

SIMBA considers headway to be the time between two successive vehicles, in the same lane, arriving 

at the detector. 
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Since SIMBA is run in discrete simulation steps, the time of arrival at the detector is based on an 

interpolation which is based on constant velocity over the simulation time-step. 

The program records headways calculated in this manner for each lane of the specified direction, and 

for the specified vehicle types. The parameters are: 

 Time Interval – the interval (in simulation time) between the detector outputs of the recorded 

data. This value can be reasonably large to avoid the slow process of accessing the hard drive. 

 Parameter A- this value specifies the location of the detector. 

Refer to Section 6.4 for information on the data output by Headway detector. 

Composition 

This detector gather the composition of the traffic stream at the detector location. Since this statistic 

only makes sense if a range of vehicle types is accounted for, it only performs output if the user 

selects “All Vehicles” or “All Trucks” in the Vehicle Type dropdown box. 

The program outputs the number of each type of vehicle to pass the detector during the previous time 

interval. Thus, the parameters are: 

 Time Interval – the interval (in simulation time) between the detector outputs. 

 Parameter A – this value specifies the location of the detector. 

Refer to Section 6.5 for information on the data output by Composition detector. 

Lane Changes 

This detector gather Lane Change statistic on road model. A Lane Change Detector takes account of 

the lane changes that occur anywhere in the specified road direction and so it is only necessary to 

specify one Lane Change Detector per direction. Specifying more Lane Change Detectors will only 

slow program’s execution. The parameters are: 

 Time Interval – the interval (in simulation time) between the detector outputs. 

 Interval – for a Lane Change Detector the ‘Interval’ is the spatial discretization required for 

outputting the lane change rate, as defined by (Kesting,A.,Treiber,M.,Helbing,D., 2007)[2]. 

This value should not more than 1000m. 

Refer to Section 6.6 for information on the data output by Lane Changes detector. 

Output Vehicles 
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This detector outputs a vehicle file reporting the arrival time and vehicle information at the detector. 

This enables further detailed assessment of traffic statistics at the point, using other software. The 

parameters are: 

 Time Interval – the interval (in simulation time) between the detector outputs. 

 Parameter A – this value specifies the location of the detector. 

Refer to Section 6.7 for information on the data output by Output Vehicles detector. 

Macro Segment 

This detector gather macroscopic statistics for a road segment, namely the space mean speed and 

density. All vehicles (of the selected vehicle type) on the road segment at the time of output contribute 

to the output statistics. This enables comparison between point detector statistics and this ‘snapshot’ 

type. 

The parameters are: 

 Time Interval – the interval (in simulation time) between the detector outputs. 

 Parameter A – this value specifies the start of the detector. 

 Parameter B – this value specifies the end of the detector. 

Refer to Section 6.8 for information on the data output by Macro Segment detector. 

 

Micro Segment 

This detector gather microscopic statistics for a road segment, namely relevant vehicle information, 

gap, position and acceleration. All vehicles (of the selected vehicle type) on the road segment at the 

time of output contribute to the output statistics. 

The parameters are: 

 Time Interval – the interval (in simulation time) between the detector outputs. 

 Parameter A – this value specifies the start of the detector. 

 Parameter B – this value specifies the end of the detector. 

Refer to Section 6.9 for information on the data output by Micro Segment detector. 

S-T Density 
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This detector gather information to prepare a space-time plot of density along the road. All vehicles 

(of the selected vehicle type) on the road segment at the time of output contribute to the output 

statistics. This statistic is useful to observe the progression of inhomogeneities in the traffic, and the 

effect of various obstructions to flow. 

The parameters are: 

 Time Interval – the interval (in simulation time) between the detector outputs. 

 Parameter A – this value specifies the start of the detector array. 

 Parameter B – this value specifies the distance interval for locating the intermediate detectors. 

 Parameter C – this value specifies the end location of the detector array. 

Refer to Section 6.10 for information on the data output by S-T Density detector. 

S-T SMS 

This detector gather information to prepare a space-time plot of space mean speed along the road. All 

vehicles (of the selected vehicle type) on the road segment at the time of output contribute to the 

output statistics. This statistic is useful to observe the progression of inhomogeneities in the traffic, 

and the effect of various obstructions to flow. 

The parameters are: 

 Time Interval – the interval (in simulation time) between the detector outputs. 

 Parameter A – this value specifies the start of the detector array. 

 Parameter B – this value specifies the distance interval for locating the intermediate detectors. 

 Parameter C – this value specifies the end location of the detector array. 

Refer to Section 6.11 for information on the data output by S-T SMS detector. 

Occupancy Segment 

This detector collects occupancy statistics for the road segment. The segment is considered occupied 

if all or part of a vehicle is on the segment. The percentage time that the segment is occupied is 

reported for a particular time interval. All vehicles (of the selected vehicle type) on the road segment 

at the time of output contribute to the output statistics. 

Occupancy is sometimes considered a point-measure, but this implementation gives the option to 

investigate longer (or typically short) stretches of road. 

The parameters are: 
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 Time Interval – the interval (in simulation time) between the detector outputs. 

 Parameter A – this value specifies the start of the detector. 

 Parameter B – this value specifies the end of the detector. 

Refer to Section 6.12 for information on the data output by Occupancy Segment detector. 

4.6 Discrete Distributions 

Users can define discrete distributions for the use in vehicle driving parameters. Probability mass 

function are defined in the dialog shown below. 

 

Discrete distribution is a symmetric probability distribution whereby a finite number of values are 

equally likely to be observed. Any number of distribution can be defined, and are saved to the *.sba 

file for later use, even if not used in the current simulation.  

Select Distribution 

To create a distribution, select the “Add New” button. To delete a distribution, select the distribution 

in the list and click “Delete Distribution” button. Both the buttons located at the top left at the dialog. 

The Select Distribution dropdown box will show a list of newly added distribution once the user has 

edit and define the distribution. There will be graph of probability mass (y-axis) against data value (x-

axis) underneath of the Select Distribution dropdown box. The graph will display based on the 

selected distribution that define by user. An example graph is shown below: 
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Edit Distribution 

The Description is the name by which the user will select the distribution in the IDM parameters 

dialog. To add row for discrete distribution, press the Add Row button and then edit the details of the 

distribution by adding value and probability. To delete a row, select the number of row from the 

dropdown list and press the Delete Row No. button. 

The data is check for the following: 

 Only non-negative data is possible, and must be in ascending order. 

 Only probability values between 0.0 and 1.0 are possible. 

 The total sum of probability must be sum to unity and equal to 1 normally. 

 Zero-rows are not permitted. 

4.7 Vehicle Type Definitions 

This dialog allow user to define different vehicle type. Vehicle Types are defined in the Vehicle Type 

definitions dialog: 
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Select Vehicle Type 

As mention earlier, the program considers 6 vehicle types (default values given): 

 Type 1 – Cars: any vehicle under 3.5 tonnes 

 Type 2 – Small Trucks: any vehicle with less than 4 axles (e.g. 2- and 3-axle vehicles) over 

3.5 tonnes. 

 Type 3 – Large Trucks: any vehicle that is not a car, small truck, crane or low-loader. 

 Type 4 – Crane: any vehicle that is not a car and has a maximum axle spacing of 4.5m and an 

average axle spacing less than 2.5m. 

 Type 5 – Low-loader: any vehicle that is not a car and has a maximum axle spacing not less 

than 7.5m. 

 Type 6 – User-Defined Vehicle: a general vehicle type allowing user to isolate particular 

vehicles of interest. This type takes precedence over all other vehicle types, so care must be 

taken that all vehicles are not assigned to this type, unless user intended to use this vehicle 

type. 

Edit Vehicle Type 

SIMBA considers these particular types of vehicles due to their importance in highway bridge traffic 

loading. 

This dialog allows the user to define the parameters that govern the type a vehicle is considered to be. 

By defining a vehicle type, the user can specify driver parameters for those vehicles, as well as restrict 

detector output to this vehicle type. This enables the user to have control over the exact subset of the 

traffic stream that is of interest.  

 Low Inclusive Limit: the limit on the lowest far-reaching value that user can define. 

 High Inclusive Limit: the limit on the highest far-reaching value that user can define. 

 No. Axles: the number where a bar or shaft on which a wheel, pair of wheels, or other rotating 

member revolves. 

 GVW (t): the parameters of the distributions that characterize the Gross Vehicle Weight and 

speed of each class of trucks for both directions. It is define in time (t). 

 Length (m): the length of the vehicle in meters (m). 

 Maximum Axle Spacing (m): The maximum allowable axle spacing in meters (m). 

 Minimum Axle Spacing (m): The minimum allowable axle spacing in meters (m). 

 Ave Axle Spacing (m): The average of the axle spacing in meters (m). 

For each type of vehicle, user can change the colour of the vehicle type at the dropdown box. 
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4.8 Bridge 

The purpose of SIMBA is to simulate traffic bridge load effect, thus user have to define bridge along 

the road model. The bridges over which vehicles are to pass are defined in the bridge definition 

configuration. Since SIMBA is a newly develop program, user can’t definite bridge by using menu 

command. There only way to define bridge is to use Simulation Elements dialog box as shown below: 

 

Steps to add a bridges are show as follows: 

1. Mouse right click on the Bridges folder in Simulation Elements dialog and select Add, 

Bridge. 

2. The bridge is added once the user mouse left click on it. User allow to add multiple bridges 

along the road model.  

3. Mouse double click on the Bridges folder, the dropbox will open and a newly created bridge 

named New Bridge No.1. The name of bridge can be change in description under Properties 

dialog box. 

 

4. Mouse double click on New Bridge No.1, the dropbox will show load effect under the New 

Bridge No.1 tree. There can be several number of load effects to be considered for the same 

bridge. 
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To Define Bridge 

Once the bridge is added in Simulation Elements dialog box, user required to define the bridge 

(especially coordinate of the bridge along the road model) in the Properties dialog box underneath 

Simulation Elements dialog box. The properties dialog box is shown below with information 

attached: 

 

 Element Type: The type of the simulation element currently selected. 

 ID: A file identifier for the bridge. 

 Start (m): Specify the start location of the bridge in global road coordinate. 

 End (m): Specify the end location of the bridge in global road coordinate. 

 Sub steps: Specify the number of bridge calculation sub-steps per simulation step. 

 No. of load effects: Specify the number of bridge calculation sub-steps per simulation step. 

Output: 

 Basic: Specify whether basic statistics for each load effect is to be output. 

 Histogram: Specify whether histogram data is to be output. 

 Time history: Specify whether a full load time history is to be output. 

 Block Maximum > Output: Specify whether block maximum loads are to be output. 

 Block Maximum > Block size(s): Specify the block size for block maximum loads output. 

 Block Minimum > Output: Specify whether block minimum loads are to be output. 

 Block Minimum > Block size(s): Specify the block size for block minimum loads output. 

 Peaks Over Thresholds > Output: Specify whether loads over particular thresholds are to be 

output. 
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 Peaks Over Thresholds > Index[1]:Specify the threshold for the load effect corresponding to 

the index (percentile of load effect, e.g. 95th percentile). 

 Peaks Under Thresholds > Output: Specify whether loads under particular thresholds are to be 

output. 

 Peaks Under Thresholds > Index[1]: Specify the threshold for the load effect corresponding to 

the index (percentile of load effect, e.g. 5th percentile). 

To Define Load Effect: 

Under the dropbox of newly define bridge, user allow to add load effect and define the load effect. 

The load effect has a close connection with the influence line, it is the result of a calculation using any 

influence line. Total load on the bridge is sometimes referred to as a load effect therefore. The 

influence line can be built-in function influence line or user-specified discrete influence line.  

 

 Element Type: The type of the simulation element currently selected. 

 ID: The index of the load effect for its bridge. 

 Description: Use a meaningful description for load effect simulation element. 

 IL Type: Select an influence line type: either a built-in function or a user-specified discrete 

influence line. 

 Function/Discrete: Choose the influence line function. 

 Index[1]: The weight for the lane of this index. 

 Index[2]: The weight for the lane of this index. 

 Index[3]: The weight for the lane of this index. 

*Note: Refer to Section 3.5 for information about the Window Properties in Properties dialog box. 
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Built-In Influence Functions 

The built-in influence functions are mathematical expressions that apply for any bridge length and can 

be weighted with any value of lane factor. Consequently, these built-in functions execute more 

quickly than read-in influence lines. 

The description and index for the built in functions are: 

Index Influence Line Location 

1 Mid-span bending moment for a simply supported beam B 

2 Bending moment over the central support of a two-span beam E 

3 Left-and shear in a simply supported beam A 

4 Right-hand shear in a simply supported beam C 

5 Right-hand shear for a two-span beam F 

6 Left-hand shear for a two-span beam D 

7 Total amount of load on the bridge (e.g. the unit influence line)  

 

 

User-specified Discrete Influence Line 

Discrete influence line is the influence line that define by user. Refer to Section 4.9 for the 

information about the Discrete Influence Line. 

 

4.9 Influence Lines 

This dialog allow user to graphs the variation of a function (such as the shear felt in a structure 

member) at a specific point on a beam or truss caused by a unit load placed at any point along the 

structure. Some of the common functions studied with influence lines include reaction, shear, moment 

and deflection. The influence lines show where a load will create the maximum load effect for any of 

the functions studied. Influence lines are defined in the dialog shown below. 
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Select Influence 

To create a new influence line (IL), select the “Add New” button. To delete an IL, select the IL in the 

list and click “Delete Influence Line” button. Both the buttons located at the top left at the dialog. The 

Select Influence dropdown box will show a list of newly added ILs once the user has edit and define 

the influence line. There will be graph of influence ordinate (y-axis) against distance (x-axis) display 

underneath of the Select Influence dropdown box. The graph will display the pattern based on the 

selected ILs that define by user. An example of ILs graph is shown below: 

 

Edit Influence Line 

To add row for influence line, press the Add Row button and then edit the details of the influence line 

by adding influence ordinate and distance in the cells below. To delete a row, select the number of 

row from the dropdown list and press the Delete Row No. button. The program able to plot the input 

influence ordinate and distance define by user as shown in the graph above.  

The data is check for the following: 
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 Can be positive or negative value for influence ordinate. 

 The distance (x-axis) must be in ascending order. 

 Prefer to use as few points as is necessary where the influence line is linear. 

 More points is required if it is curved line. 

*Note: If the last coordinate in x-axis doesn’t match the bridge length defined earlier may result in 

program crash. 

5.0 Running SIMBA 

 

5.1 Introduction 

The usual procedure followed when using the program is: 

1. Define input data either by using the configuration dialogs (Section 4) or by opening an *.sba 

file that saved in previous work. 

2. Run the program in Visible Mode (Section 5.2) to view the behaviour of the traffic (Section 3) 

and to obtain intermediate information (Section 3.5). 

(Able to run as single step or invisible mode, depends on what’s user want to be done.) 

3. Examine the various detector output files using a *.csv file viewer, such as Microsoft Excel. 

4. Examine the various load effect graph display in program, the load effect currently included is 

maximum load effect and minimum load effect. 

The user preferences and configuration preferences required for the program are explained next. 

5.2 Simulation Modes 

Introduction 

Three modes of running the simulations are provided to meet the aims of the program. 

Visible Mode  

In this mode, the user can interact with the program at any stage of the simulation and change 

visualisation parameters via the User Preferences dialog box (Section 5.3). This mode able to display 

the whole road model define by user and displays the animation of vehicle along the road on screen in 

program. The animation can be paused or stopped at any time. Whilst paused, information on vehicles 

can be got though the DataTips (Section 3.5) by clicking on selected vehicles. Besides that, a 

screenshot of the road model may be taken during the simulation by using the File > Save Image 
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command (or keyboard shortcut Ctrl + I). These features make the Visible Mode an interactive 

environment for the calibration of a traffic model. 

The features described for Visible Mode above come at the expense of execution time. Simulation is 

run in simulation steps per second and it is normally start simulate at time warp factor of 1.0. Time 

warp factor is the ratio between simulation time and real time. To fast forward, the recommended 

maximum time warp factor is roughly 15. While rendering the simulation, interruption of the 

simulation by interacts with the program will results cannot obtained as fast as possible. Further, this 

mode requires that the program ‘sleep’ for a period during each simulation step in order that the 

animation of vehicles is done at a slow enough speed for human eyes to perceive. Invisible Mode 

rectifies these issues as it is optimised for speed of execution.  

Single Step 

Run as single step allow user to progress the simulation by a single step at each time user press on the 

button. Every time when the user click on the button, the simulation steps is 0.25. Hence the single 

step is quarter or 0.25 of the simulation steps per second. The single step mode doesn’t affect the 

visualisation of the road model, it paused at 0.25s of simulation of display animation on screen every 

time user click on it. This mode is easier for user to record every vehicle DataTip running in the road 

model in early stage. Pause and unpausing function are not available for this running mode.  

*Note: This mode is not recommended to run the whole simulation process as it is time consuming.  

Invisible Mode 

In this mode, the simulation run in a background process with timer. It runs without animation of 

vehicle as well as road model on the screen. The simulation able to run as fast as possible as 

compared to visible mode and the timer will updates in the main window. The timer updating is 

therefore the only indication for user to know the program is running. This mode can run very fast 

with time warp factor over 5000 achieved (but it is depends on complexity of input configuration such 

as road feature, traffic, lane changes, detector output, etc.).In order to get result in shorter time period 

and fast execution, invisible mode is recommended.  

Users with single-core processers may not be able to use other programs and the computer may 

appear frozen until the simulation is complete. For such users, to optimise simulation times, it is 

advised that no other programs be running at the same time. Besides that, the simulation still running 

even if the computer in “sleep” mode. 
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5.3 Program Preferences 

Ordinary User Preferences 

User preferences can be specified though the User Preferences dialog, shown here:  

 

The parameters are: 

 Overall scale (pixel/metre): the current scale of the drawing on viewport. 

 Widths Scale: the exaggeration applied to the road and vehicle widths so that it is easier to 

visualize the vehicles. 

 Lane width (m): the width of a lane as drawn prior to application of the Widths Scale factor. 

 Vehicle width (m): the width of a vehicle as drawn prior to application of the widths scale 

factor.  

 Vehicle Length Scale: a factor that allows the length of a vehicle to be exaggerated in order 

that a more reasonable aspect ration is kept once the widths scale factor has been applied. 

Note that when this is not unity it can appear that vehicles overlap on the road when very 

close (bumper-to-bumper traffic), set this to unity to observe that this is not the case. Note 

also that the vehicle length is exaggerated from the front of the vehicle, that is, the extra 

length is applied to the back of the vehicle always. 

 Show Velocities: set this value to “0” to turn off (any other value to turn it on) the display of 

the velocities of each vehicle shown below. The little block on road model represent the 

various type of vehicle.  
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 Show Legend: set this value to “0” to turn off (any other value to turn it on) the display of the 

legend below the road model. An example of legend is shown below: 

 

 Tick Length (m): the length of the ruler ticks. 

 Tick Interval (m): the interval between ruler ticks and distance displays. 

 Border Top (m): the border between the top of the screen and the clocks. 

 Border Bottom (m): currently obsolete. 

 Border Left (m): the border between the start of the road and the edge of the window. 

 Border Right (m): the border between the end of the road and the edge of the window. 

5.4 Example Road Model 

In order to get a better understanding of how’s the SIMBA looks like, there is a sample of road model 

screenshot shows in this section. The example cover the road features and macroscopic traffic flow 

metrics detectors. Apart from that, it is run as visible mode to see the example, otherwise in Invisible 

Mode to get straight to the detector output. 

This example shows a road model that contain 3000m length with a bridge located between 1000m 

and 1040m. The road model is 2 lanes model as shown below: 

 

Road feature for both lanes that include in this example is the gradient and speed limit. The speed 

limit is 60km/h at the region of 1000m to 1500m. Furthermore, there is two section of road contain 
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road gradient, which is 800m to 1000m and 2500m to 2700m. Total of 4 flow & density detector is 

located along the road model, the detector output able to give output data to user for further analysis. 

In this case, 2 detectors located at 1000m for both direction and the other 2 detectors located at 2500m 

of both direction.  

 

6.0 SIMBA Output 

6.1 Introduction 

SIMBA is an interactive programming environment that facilities dealing with traffic analysis along 

the road model and bridge. It has the ability to produce large amounts of output, especially for long 

run simulations or heavily congested traffic. The program’s execution time is depends on the 

complexity of road model and accessing hard drive often slow down the program’s execution. 

Therefore it is recommended that statistical detector output is only used when required for calibrating 

the IDM traffic parameters. For execution of the program for the sole purpose of obtaining another 

randomized traffic file, based on calibrated IDM parameters, it is better to have no detector output. 

As mention earlier in Section 4.5, the Macroscopic Traffic Flow Metrics Detectors is important as it 

give output data at the end of the simulation. The type of detectors that allow user to add in includes: 

Flow & Density, Headway, Composition, Lane Changes, Output Vehicles, Macro Segment, Micro 

Segment, S-T Density, S-T SMS and Occupancy. All type of detectors able to generate various type 

of statistic data in tabulation form in Comma-Separated Values (*.csv) file format which can be read 

by any spreadsheet viewer, such as MS Excel.  

Apart from Detectors Output, SIMBA able to generate load effects that happen on the bridge. Load 

effects is the result of a calculation using any influence line, total load on the bridge is sometimes 

referred to as a load effect. SIMBA can output some useful summary statistics of the calculated load 

effects and load effect graph display in the program itself. While running the simulation, the load 

effect graph at the bottom of the road model screen will show the load effect red line fluctuated when 

moves along the time. The load effect graph may be taken during the simulation by using the File > 

Save Chart command (or keyboard shortcut Ctrl + J). 

6.2 Output File 

All the output file is saved to the location defined by user (Section 4.2) output directory. Once the 

configuration is set and bridge is defined, the road model can start simulate. When the user press on 

the “Run” button, validation dialog box will check whether the road model is valid or invalid. If the 
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road model is valid, the simulation will run automatically. Else, validation report will show the error 

and user have to make rectification on the configuration or defined bridge.  

 While running the simulation, the output data will automatically save into file named: 

Metrics_xxxxxx-tttttt 

Where: 

 Metrics- means Metrics directory 

 xxxxxx- represent the date that user run the simulation (e.g. 20150815 mean 15th August 2015) 

 tttttt- represent the time that user run the simulation (e.g.143906 mean 14:39:06) 

All the detectors output and load effect statistics data can be found inside this “Metrics” file.  

6.3 Flow & Density 

File  

The output for a Flow Density Detector is made to the following file: 

FD_vvv_ddd_xxxxx.csv 

Where: 

 FD- means Flow Density detector file 

 vvv- the vehicle type for which the output is made, it can be: 

o All- for all vehicles output 

o Trucks- for all trucks output 

o Car- for car only output 

o ST- for small truck only output 

o LT- for large truck only output 

o Crane- for crane only output 

o LL- for low-loader only output 

 ddd- the direction identifier: 

o Pos- for the positive x direction (consist of 1 or more lanes) 

o Neg- for the negative x direction (consist of 1 or more lanes) 

 xxxxx- a number representing the location of the detector in metres 

Output 

An example Flow & Density output (*.csv) for one-lane direction shows below: 
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 The format of the Flow Density Output is: 

 The first row, contains number of lanes and totals of each four columns of density, flow, 

space mean speed and time mean speed. 

 The first column, contains an index representing the time interval for which the output was 

made. 

Next, for each lane in the direction that the detector considers, for the particular time interval 

considered, we have four columns: 

 Density (veh/km)- the measured traffic density of the vehicles considered. 

 Flow (veh/hr)- the flow of the vehicles considered. 

 Space Mean Speed (km/h)- the harmonic average velocity of the vehicles considered. 

 Time Mean Speed (km/h)- the average velocity noted over the time interval considered. 

Finally, under the “Totals”, each columns of density, flow, space mean speed and time mean speed for 

each lane (if there is 2 or more lanes in data file) has been add up separately to give a total of density, 

flow, space mean speed and time mean speed.  

 

6.4 Headway 

File 

The output for a Headway Detector is made to the following file: 

 Head_vvv_ddd_xxxxx.csv 

Where: 

 Head- means Headway detector file 

 vvv- the vehicle type for which the output is made, it can be: 

o All- for all vehicles output 

o Trucks- for all trucks output 

o Car- for car only output 
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o ST- for small truck only output 

o LT- for large truck only output 

o Crane- for crane only output 

o LL- for low-loader only output 

 ddd- the direction identifier: 

o Pos- for the positive x direction (consist of 1 or more lanes) 

o Neg- for the negative x direction (consist of 1 or more lanes) 

 xxxxx- a number representing the location of the detector in metres 

Output 

An example of headway output (*.csv) is given as below: 

 

Headway is a measurement of the time between vehicles in a transit system. It is measured as the time 

taken from the top of one vehicles to the tip of the next on behind it.  

The format of Headways: 

 The first row, is the Headway Output title and it is outputs the vectors of headways (in 

seconds) at each time interval, for the vehicle types considered, for each lane for the direction 

which the detector covers. 

 The second row, the number of lanes (if there is lane 2, the 2nd column will display the results 

of lane 2). 

Next, for each lane in the direction that the detector considers, for the particular time interval 

considered (in this example, time interval is 300s), we have separate columns for separate lanes. 

Note from the example that the first vehicles have larger headways than usual (since there is no 

vehicle in front). Also notice that at cell (A9) the headway is largest, which mean the traffic condition 

of road model is smooth and no much vehicle on road. 
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6.5 Composition 

File 

The output for a Composite Detector is made to the following file: 

 Comp_vvv_ddd_xxxxx.csv 

Where: 

 Comp- means Composite detector file 

 vvv- the vehicle type for which the output is made, it can be: 

o All- for all vehicles output 

o Trucks- for all trucks output 

o Car- for car only output 

o ST- for small truck only output 

o LT- for large truck only output 

o Crane- for crane only output 

o LL- for low-loader only output 

 ddd- the direction identifier: 

o Pos- for the positive x direction (consist of 1 or more lanes) 

o Neg- for the negative x direction (consist of 1 or more lanes) 

 xxxxx- a number representing the location of the detector in metres 

Output 

An example of Composite output (*.csv) is given as below: 

 

The composition output for each time interval is simply the count of the number of vehicles of various 

vehicle type that passed through the detector during the previous time interval.  

The format of Composition: 

 The first columns, indicate the time interval in second. (e.g.300s in this example) 
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 The second columns, indicate the number of cars passed through as per time interval. 

 The third columns, indicate the number of small trucks passed through as per time interval. 

 The fourth columns, indicate the number of large trucks passed through as per time interval. 

 The fifth columns, indicate the number of cranes passed through as per time interval. 

 The sixth columns, indicate the number of low-loaders passed through as per time interval. 

 The seventh columns, indicate the number of user-define vehicles passed through as per time 

interval. 

 

6.6 Lane Changes 

File 

Lane Changes features only applicable for 2 or more lanes in each positive or negative x direction. No 

result will be given if there is one lane in each positive or negative x direction. The output for Lane 

Change Detector is made up of the following files: 

LC_All_vvv_ddd.csv 

LC_Comp_vvv_ddd.csv 

LC_Rate_vvv_ddd.csv 

LC_ST_vvv_ddd.csv 

Where: 

 LC- means Lane Changes detector file 

 All- raw information relating to lane change events 

 Comp- composition of lane change events 

 Rate- Lane change rate 

 ST- Space time of lane change events 

 vvv- the vehicle type for which the output is made, it can be: 

o All- for all vehicles output 

o Trucks- for all trucks output 

o Car- for car only output 

o ST- for small truck only output 

o LT- for large truck only output 

o Crane- for crane only output 

o LL- for low-loader only output 
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 ddd- the direction identifier: 

o Pos- for the positive x direction (consist of 1 or more lanes) 

o Neg- for the negative x direction (consist of 1 or more lanes) 

Output (The LC_All File) 

An example of file outputs the raw information relating to lane change events: 

 

The format of LC_All file in (*.csv) is: 

 1st column (Time): the time at which lane change vene took place 

 2nd column (Position): the location (as measured from the start of the road) of the lane change 

 3rd column (From Lane): the lane number that the vehicle moved from 

 4th column (To Lane): the lane number that the vehicle moved to 

 5th column (Right/Left): whether the vehicle moved left or right 

 6th column (Type): the type of vehicle that changed lane in road model 

The example shows the type of vehicle changed lane at the exact location in metres and time in 

second when the vehicle changed lane. It also shows the vehicle changed lane from particular lane to 

another lane. 

Output (The LC_Comp File) 

An example of file outputs information pertaining to the composition of lane change events by vehicle 

type: 
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This output file only applicable if the vehicle type for this detector is all vehicle type. No result will 

be given if user select other vehicle types. 

At each time interval defined by user, composition of lane change output file display number of each 

vehicle type changed lane. It’s included all type of vehicles: car, small trucks, large trucks, cranes, 

low loaders and user defined vehicle. 

In the example above, the first 60 second time interval shows that 3 car changed lane while the 

retaining type of vehicle doesn’t make any lane changed. 

Output (The LC_Rate File) 

An example of file output the lane change rate for each time interval for each road interval along the 

road model: 

 

From the example above, the format of lane change rate output is: 

 1st column, the time interval define by user in second. 

 3rd row, the interval of road model in metres defined by user (it should not more than 1000m, 

e.g.200m) 

Next, the lane change rate is measure in units of number of lane changes per hour per kilometre 

(1/hr/km). This metric is as defined in the paper on the lane change model by 

(Kesting,A.,Treiber,M.,Helbing,D., 2007)[2]. The lane change rate is: 
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𝑟(𝑝, 𝑥, 𝑡) =
𝑛𝐿𝐶

𝛥𝑡. 𝛥𝑥
 

Where: 

 𝑟(𝑝, 𝑥, 𝑡) is the lane change rate, and is a function of both time, distance and traffic density 

 𝑛𝐿𝐶 is the number of lane changes that occurred in the time interval, 𝛥𝑡 

 𝛥𝑡 and 𝛥𝑥 are the temporal and spatial discretization 

The lane change rate is measure in units of number of lane changes per hour per kilometre (1/hr/km). 

Taking 𝛥𝑡= 1min. and 𝛥𝑥 = 200m, a single lane change is equivalent to a lane change rate of: 

1

(1/60)(200/1000)
=300/hr/km 

Therefore the lane change rate values in the file will tend to be round numbers due to the above 

calculations. Further, this metric is calculated for each time interval at each step along the road, 

leading to a large matrix of lane change rates. 

From example above, it is apparent that there is significant lane changing at 200m at each time 

interval. This is caused by road closure ahead at this point in the road model. 

Output (The LC_ST File) 

An example of file output the time and position of each lane change event for both Left to Right 

changes, and for Right to Left changes, for the direction that the detector is applied to: 

 

From the example above, the output file shows at each lane changed at particular time and particular 

location. There are a number of vehicle changed lane from left to right and number of vehicle change 

from right to left. Also, there are a number of vehicle returning to the original lane after make an 

overtaking.  
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6.7 Output Vehicles 

File 

The output for an Output Vehicles Detector is the only text file (*.txt) in this case and it is made up of 

the following file: 

Veh_vvv_ddd_xxxxx.txt 

Where: 

 Veh- means Output Vehicles detector file 

 vvv- the vehicle type for which the output is made, it can be: 

o All- for all vehicles output 

o Trucks- for all trucks output 

o Car- for car only output 

o ST- for small truck only output 

o LT- for large truck only output 

o Crane- for crane only output 

o LL- for low-loader only output 

 ddd- the direction identifier: 

o Pos- for the positive x direction (consist of 1 or more lanes) 

o Neg- for the negative x direction (consist of 1 or more lanes) 

 xxxxx- a number representing the location of the detector in metres 

Output 

An example of file that output vehicle data in text file format: 
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The vehicles are output as per the regular Output Detectors in the same file format (CASTOR, SAFT, 

or BeDIT) as the input traffic file. 

6.8 Macro Segment 

File 

The output for a Macro Segment Detector is made to the following file 

Macro_vvv_ddd_xxxxx.csv 

Where: 

 Macro- means Macro Segment detector file 

 vvv- the vehicle type for which the output is made, it can be: 

o All- for all vehicles output 

o Trucks- for all trucks output 

o Car- for car only output 

o ST- for small truck only output 

o LT- for large truck only output 

o Crane- for crane only output 

o LL- for low-loader only output 

 ddd- the direction identifier: 

o Pos- for the positive x direction (consist of 1 or more lanes) 

o Neg- for the negative x direction (consist of 1 or more lanes) 

 xxxxx- range of detector from one location to another along the road model in metres 

Output 

An example of Macro Segment output file: 

 

The output for each time interval is the exact density and space mean speed on the road segment at the 

instant of output. This information is given for each lane, as well as the total for the direction. 
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As shown in the example, at each time interval, there is different density and space mean speed on the 

selected road segment at each lane of road.  

6.9 Micro Segment 

File 

The output for a Micro Segment Detector is made to the following file 

Micro_vvv_ddd_xxxxx.csv 

Where: 

 Micro- means Micro Segment detector file 

 vvv- the vehicle type for which the output is made, it can be: 

o All- for all vehicles output 

o Trucks- for all trucks output 

o Car- for car only output 

o ST- for small truck only output 

o LT- for large truck only output 

o Crane- for crane only output 

o LL- for low-loader only output 

 ddd- the direction identifier: 

o Pos- for the positive x direction (consist of 1 or more lanes) 

o Neg- for the negative x direction (consist of 1 or more lanes) 

 xxxxx- range of detector from one location to another along the road model in metres 

Output 

An example of Micro Segment output: 

 

The output for each time interval is made for each vehicle as per the example output above. The 

format of Micro Segment output is: 

 1st column, time interval 
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 2nd column, the vehicle ID that assigned as the order of appearance earlier in the input traffic 

file. 

 3rd column, the type of vehicle that defined by user in early stage 

 4th column, the length of the vehicle 

 5th column, the position in local lane coordinate 

 6th column, the gap between vehicle (from back of vehicle to head of vehicle behind) 

 7th column, the front vehicle ID is the vehicle ID at the front of selected vehicle 

 8th column, the velocity (speed) of vehicle in km/h 

 9th column, the acceleration of vehicle in m/s2 

From the example above, there is a number of empty cells at the first 300 seconds which indicate 

there is no vehicles enter the selected region during the first 300 seconds. 

6.10 S-T Density 

File 

The output for an S-T Density Detector is made to the following file 

STD_vvv_ddd_xxxxx.csv 

Where: 

 STD- means Space-Time Density detector file 

 vvv- the vehicle type for which the output is made, it can be: 

o All- for all vehicles output 

o Trucks- for all trucks output 

o Car- for car only output 

o ST- for small truck only output 

o LT- for large truck only output 

o Crane- for crane only output 

o LL- for low-loader only output 

 ddd- the direction identifier: 

o Pos- for the positive x direction (consist of 1 or more lanes) 

o Neg- for the negative x direction (consist of 1 or more lanes) 

 xxxxx- range of detector from one location to another along the road model in metres 

Output 

An example of S-T Density output: 
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The output for each time interval is a density estimate (based on the harmonic estimate of space mean 

speed) at each detector point in array (distributed along the road according to the start-interval-end 

parameters). The output is formatted in such a way that three-dimensional plotting is easily facilitated. 

For each lane of the direction, and for the total in each direction, the density at for each time interval 

is given on a row under a column corresponding to the location of each detector.  

6.11 S-T SMS 

File 

The output for an S-T SMS Detector is made to the following file 

STSMS_vvv_ddd_xxxxx.csv 

Where: 

 STSMS- means Space-Time Space Mean Speed detector file 

 vvv- the vehicle type for which the output is made, it can be: 

o All- for all vehicles output 

o Trucks- for all trucks output 

o Car- for car only output 

o ST- for small truck only output 

o LT- for large truck only output 

o Crane- for crane only output 

o LL- for low-loader only output 

 ddd- the direction identifier: 

o Pos- for the positive x direction (consist of 1 or more lanes) 

o Neg- for the negative x direction (consist of 1 or more lanes) 

 xxxxx- range of detector from one location to another along the road model in metres 

Output 

An example of S-T SMS output (*.csv) is given as below: 
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The output for each time interval is a space mean speed estimate (based on the harmonic estimate) at 

each detector point in the array (distributed along the road according to the start-interval-end 

parameters). The output is formatted similar to the S-T Density output. 

6.12 Occupancy Segment 

File 

The output for an Occupancy Segment Detector is made to the following file 

Occup_vvv_ddd_xxxxx.csv 

Where: 

 Occup- means Occupancy Segment detector file 

 vvv- the vehicle type for which the output is made, it can be: 

o All- for all vehicles output 

o Trucks- for all trucks output 

o Car- for car only output 

o ST- for small truck only output 

o LT- for large truck only output 

o Crane- for crane only output 

o LL- for low-loader only output 

 ddd- the direction identifier: 

o Pos- for the positive x direction (consist of 1 or more lanes) 

o Neg- for the negative x direction (consist of 1 or more lanes) 

 xxxxx- range of detector from one location to another along the road model in metres 

Output 

An example of occupancy output file:  



SIMBA (v1.5.2.0)  User Manual 

 

Colin Caprani Page 70 
 

 

The format of occupancy output file is: 

 1st column, the time interval 

 2nd column onwards, the number of lane in road model defined by user 

The output for each time interval is the percentage time the segment was occupied by a vehicle among 

the vehicle files. Output is for each lane in the direction. There is no total direction output as this has 

no real meaning. 

From the example above, the first 420 seconds time interval doesn’t have vehicle enter the selected 

lane and segment. But lane 2 has 0.042266% of vehicle enter the segment at 480 seconds time. 

6.13 Load Effect Statistics Output 

File 

The output for Load Effect Statistics Output is made up of following files: 

Br_n_Stats_Basic_xxxxx.csv 

Br_n_Stats_Hist_xxxxx.csv 

Where: 

 Br- means bridge 

 n- number of bridge 

 Stats- Statistic of load effect 

 Basic- Basic statistics for each load effect 

 Hist- Histogram data of load effect 

 xxxxx- span and location of the bridge along the road model 

Output (Basic) 
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An example of Basic statistic output (*.csv) is given as below: 

 

As shown in the example above, SIMBA able to output useful summary statistics of the calculated 

load effects. The summary statistics that covered are: 

 Count – The events count 

 Min – Minimum load effect 

 Max – Maximum load effect 

 Mean – Average of load effect 

 Variance – Measures how far a set of load effects is spread out 

 Std.Dev – Standard deviation that measure to qualify the amount of variation of a set of load 

effects 

 CoV – Kurtosis that measure the “peakedness” of distribution of the load effects. 

 Skewness – Measure of the asymmetry of the load effect distribution. 

The 2nd column and 3rd column onwards indicate different type of load effect, it is depends on how 

many influence line defined by user previously.  

Output (Hist) 

An example of Histogram statistic output (*.csv) is given as below: 
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The format of histogram output file is: 

 1st column, the binomial distribution where the load effect value that history fall into 

 2nd column, the percentage of vehicle density 

The binomial distribution can be negative value while the value of density is not more than 1 and 

must be positive density value. The data is obtained at the selected segment defined by user. 

6.14 Time History 

File 

The output of Time History is made to the following file 

Br_n_vvv_xxxxx.csv 

Where: 

 Br- means bridge 

 n- number of bridge 

 vvv- the vehicle type for which the output is made, it can be: 

o All- for all vehicles output 

o Trucks- for all trucks output 

o Car- for car only output 

o ST- for small truck only output 

o LT- for large truck only output 

o Crane- for crane only output 

o LL- for low-loader only output 

 xxxxx- span and location of the bridge along the road model 

Output 

An example of Time History output is: 
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The file gives the load effect at each time step of the simulation for each load effect considered for the 

bridge. The format of output file is: 

 1st column, the current time. Note that time starts at the time of arrival of the first vehicle 

 2nd column onwards, the current value of each load effect is given 

From example, as the time increase, the value of load effect increase gradually along the defined 

bridge. 

6.15 Block Max.& Min. 

File 

The output for Block Maximum and Block Minimum is made up of following files: 

Br_n_BMax_xxxxx.csv 

Br_n_BMin_xxxxx.csv 

Where: 

 Br- means bridge 

 n- number of bridge 

 BMax- block maximum 

 BMin- block minimum 

 xxxxx- span and location of the bridge along the road model 

Output (Block Maximum) 

An example of Block Maximum file is shown below: 

 

The format of Block Maximum output file is: 

 1st column, the block index 

 2nd column, the time at which the block maximum load was found in second 
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 3rd column, the value of block maximum load output 

 The following column will repeat the time and different number of load effect considered 

The file gives the maximum load effect recorded during each block, broken down according to the 

time for each number of load effect. 

Output (Block Minimum) 

An example of Block Minimum file is shown below: 

 

The format of Block Minimum output file is: 

 1st column, the block index 

 2nd column, the time at which the block minimum load was found in second 

 3rd column, the value of block minimum load output 

 The following column will repeat the time and different number of load effect considered 

The file gives the minimum load effect recorded during each block, broken down according to the 

time for each number of load effect. 

6.16 Peak Over Threshold & Peak Under Threshold 

File 

The output for Peak Over Threshold and Peak Under Threshold are made up of following files: 

Br_n_POT_xxxxx.csv 

Br_n_PUT_xxxxx.csv 

Where: 

 Br- means bridge 

 n- number of bridge 

 POT- peak over threshold 

 PUT- peak under threshold 
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 xxxxx- span and location of the bridge along the road model 

Output (Peak Over Threshold) 

An example Peak Over Threshold is given as follows: 

 

The format of the Peak Over Threshold files is: 

 1st column, the time at which the peak loads occurred over particular thresholds 

 2nd column onwards, the peak load effect value over particular thresholds 

The threshold index is normally set range between 50th percentile to 99th percentile of load effect 

distribution. The peak data occurred beyond the percentile will recorded and tabulated as the example 

above. 

In the example above, the threshold index is set to be 95th percentile of load effect distribution. When 

the peak of load effect exceed 95th percentile of load effect distribution, data will be recorded with the 

time at which the peak loads occurred. In output file, there are some cells are empty which represent 

the load effect doesn’t exceed the threshold at the particular time. 

*Note, if the threshold index defined by user is too small, the simulation required longer time to 

complete because it outputs all the load effect model.  

Output (Peak Under Threshold) 

An example Peak Under Threshold is given as follows: 

 

The format of the Peak Under Threshold files is: 

 1st column, the time at which the peak loads occurred under particular thresholds 

 2nd column onwards, the peak load effect value under particular thresholds 
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The threshold index is normally set range between 1st percentile to 50th percentile of load effect 

distribution. The peak data occurred below the percentile will recorded and tabulated as the example 

above. 

In the example above, the threshold index is set to be 5th percentile of load effect distribution. When 

the peak of load effect below 5th percentile of load effect distribution, data will be recorded with the 

time at which the peak loads occurred under 5th percentile threshold. In output file, there are some 

cells are empty which represent the load effect doesn’t under the threshold at the particular time. 

*Note, if the threshold index defined by user is too large, the simulation required longer time to 

complete because it outputs all the load effect model.  
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