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1. Introduction 

1.1 The EvolveTraffic Program 

EvolveTraffic is a program that simulates driving behaviour for the purpose of 

estimating highway bridge loading. Vehicles are read into the program and they are 

simulated driving along a road which may have speed limit sections and gradient 

sections. The vehicles interact with one another and may perform lane changes. 

Various statistics of the traffic can be output at various points along the road. When 

the vehicles pass the Output Detector they are written to the output file. 

 

The output traffic file contains the same vehicles as the input traffic file, but 

represents a different configuration (or order) of the traffic, one that depends on the 

features the user has specified for the traffic and road. This new configuration of 

traffic is useful for bridge loading because it essentially extends measured data, 

which is expensive to obtain. 
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1.2 The User Manual 

Purpose 

This User Manual has been written to explain the use of the EvolveTraffic 

program, and to explain its capabilities and limitations. It explains the user interface, 

the required input information, and the output information. 

 

This manual does not explain the Intelligent Driver Model (IDM) used for the traffic 

microsimulation in the program. Further, it does not explain how the input data is to 

be prepared or how the program output is to be used. 

 

Conventions 

Menus 

Menu commands are written as: 

Configuration > Simulation 

And mean the user should select Simulation from the Configuration menu as shown: 

 

 
 

Keyboard 

The use of shortcut keys is indicated as: 

 Ctrl+I 

And means that the user should press the Control and “I” keys simultaneously. 
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Notices 

Points of significant importance are denoted as: 

 Important! 

Typically, failure to adhere to these points will result in unexpected behaviour or a 

program crash. 

 

Parameters that may be changed in the EvolveTraffic.ini configuration file 

are coloured in green as: 

 3.5 tonnes 

Values in this text are default values and may be changed by a Developer User. 
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Glossary 

Detector A ‘virtual’ loop detector – a location on the road where information 

on the traffic flow passing that point/road segement is abstracted. 

IDM Intelligent Driver Model – the microsimulation model used in the 

current version of the program. 

Invisible Mode A simulation is run with no output to screen (except for the 

progress bar indicator) and no user interaction allowed. 

MOBIL Minimize Overall Braking Induced by Lane changes – the lane 

change model developed by Treiber. 

Output Detector When a vehicle passes this form of detector, it is written to file 

along with its arrival time at the detector. Every road and direction 

must have these detectors since they are the reason for the 

program’s development. 

Visible Mode A simulation is run so that the vehicles are animated on the screen 

and user interaction with the program can occur. 

Road Feature Any ‘feature’ of the road – currently only speed limit sections of 

road, and sections of road with gradient are considered. 

SDI Single Document Interface – the program operates on one 

EvolveTraffic file at a time, similar to the way NotePad in 

Windows operates. 

Treiber Dr. Martin Treiber, Technische Universtät Dresden, developer of 

the IDM traffic microsimulation model [2]. 
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1.3 Release History 

EvolveTraffic Program 

Version Date Description 
1.0 22/8/08 • Initial release. 

1.0.1 1/9/08 • Bug fix: SAFT file format – removed unnecessary GVW 
kN to kg/100 conversion. 

1.0.2 10/9/08 • Bug fix: Cars were being identified as small trucks – 
fixed. 

• Bug fix: background to legend entities were coloured 
when no road features were to be drawn – fixed. 

• Bug fix: the lane number of Direction 2 vehicles was 
incorrect for CASTOR output – fixed. 

• Bug fix: a base year of 2005 was assumed in reading the 
traffic file. This is changed to 2000. 

• Bug fix: SAFT file format now padded with zeros for 
POLLUX to read. 

• Disabled for release: Added option to output cars to 
output traffic file or not – useful when only truck-loading 
is of interest. Note this requires the *.etr file structure 
to change and this change is not backward compatible. 

1.0.3 14/9/08 • Bug fix: text for road features in single lane roads was off 
centre – fixed. 

• Added support for “All Trucks” output in the detectors 
dialog and throughout program. 

1.0.4 6/8/09 • Distributions in IDM parameter box re-ordered. 
• Gap information added to vehicle information tooltip. 
• Revised calculation of flow and density output to use the 

space-mean velocity. 
• Bug fix: simulation does not end due to DirNegEmpty set 

to false when only one direction – fixed. 
1.0.5 14/5/10 • Added BeDIT file format as input/output option. 
1.0.6 

 
 
 
 

29/5/10 
 
 
 
 

• Fixed small bug in BeDIT format. 
• Fixed bug so output detector can be at end of road. 
• Fixed overlapping problem by removing limit on 

decelerations; ensuring positive gaps between vehicles; 
and modifying lane change scenario calculations. 
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1.1 11/4/11 
 
 
 
 
 

• Improved range of detectors, now including point, array 
and road segment types. 

• Revised some aspects of the user interface accordingly 
• Revised the *.etr file format accordingly 
• Revised the configuration file format accordingly 
Note: These changes are not backward compatible. 

1.2 20/4/11 • Multithreading implemented for the Run Invisible mode. 
This makes the application GUI responsive to user 
interaction during the simulation. 

• Mute detectors option added 
• Front vehicle ID output added to Microscopic detector 
• Bug fix: drawing macro detectors 
• All compiler warnings eliminated 
• File output buffer of 1MB added to all detectors to 

reduce hard drive accesses 
• GUI commands enabled/disabled as appropriate 
• Splitter window removed to eliminate potential bugs 
• Improved drawing flicker and mouse events. 
• Added support for user-defined vehicle type. 
• Restructured vehicle types definitions for future 

expansion. 
• Improved time warp in visible mode by adding 

View.TIMEWARP_SIMSTEP configuration variable. 
• Revised the *.etr file format according to above 

changes. 
1.2.1 26/4/11 • Bug fix: Only direction 2 vehicles were being outputted 

to default output detectors. 
1.2.2 9/6/11 • Bug fix: Negative direction road feature and output 

detector location corrected. 
• Bug fix: vehicle class is now properly identified. 
• Ensured randomly generated IDM parameters will be 

positive. 
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EvolveTraffic Manual 

Version Date Description 
0.9 22/8/08 Initial release. 
0.91 1/9/08 • Updated EvolveTraffic version number. 

• Added manual and program release histories. 
0.92 10/9/08 Updated manual for v1.0.2 
0.93 14/9/08 Updated manual for v1.0.3 
0.94 6/8/09 Updated manual for v1.0.4 
1.0.5 14/5/10 • Updated manual for v1.0.5  

• Merged program and manual version numbers 
1.0.6 
1.1 
1.2 

14/5/10 
11/4/11 
20/4/11 

Updated manual for v1.0.6 
Updated manual for v1.1 
Again for v1.2 
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2. Installing the Program 

2.1 System Requirements 

The program has been tested on Windows XP and Windows 7. It is expected to run 

on Windows Vista and on Windows 2000 also. 

 

The program is a single-threaded application and so cannot take advantage of multi-

core processors. Therefore for maximum speed, prefer a computer with a fast single 

processor over a computer with a multi-core slower processor. 

 

The program does not require much memory because: 

• the input file is read in line by line as required with a buffer of (default) 10 

vehicles being held; 

• the memory a vehicle uses is released when the vehicle leaves the road; 

• memory used for the storage of the metrics detectors data is released upon 

writing to file, which occurs at user-specified intervals (typically about 60 

seconds of simulation time). 

 

For long roads with a large output time interval a computer with 1 GB of RAM is 

recommended so that other programs can continue to operate successfully. 
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2.2 Installation 

To install the program, carry out the following steps: 

1. Extract the zip-archive to a folder; 

2. In that folder, double click on the file Setup.exe; 

3. Follow the on-screen instructions to install the program. 
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3. About EvolveTraffic 

3.1 Introduction 

EvolveTraffic broadly performs the following steps: 

1. A file containing a record of vehicles is opened and linked to (the ‘traffic file’); 

2. The simulation commences; 

3. Vehicles are read from the traffic file and enter the road at the time indicated in 

the traffic file; 

4. The vehicles proceed along the road with the driving behaviour simulated user 

a traffic microsimulation model; 

5. When a vehicle arrives at an Output Detector, it is written to the output traffic 

file, with the time of arrival at the Output Detector. 

6. The simulation progresses until all vehicles have been read from the traffic file 

and have exited the road. 
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3.2 EvolveTraffic: Capabilities and Limitations 

Capabilities 

EvolveTraffic is able to: 

• Read data from CASTOR, SAFT or BeDIT format vehicle files; 

• manipulate vehicles according to the IDM traffic microsimulation model as 

they progress along a road; 

• consider 5 classes of vehicle: cars, small trucks, large trucks, cranes and low-

loaders; especially chosen for their relevance to bridge loading. 

• model roads of up to 8-lanes in width, 4 per direction; 

• model one or two directions at the same time, each of up to 4 lanes; 

• take account of speed limit sections of road; 

• take account of gradient sections of road; 

• consider overlapping gradient and speed limit sections of road; 

• output vehicles to file along with their arrival times at the output detector; 

• output Flow & Density information for specified locations on the road at 

specified time intervals, for specified classes of vehicles; 

• output Headway information for specified locations on the road at specified 

time intervals, for specified classes of vehicles; 

• output traffic Composition information for specified locations on the road at 

specified time intervals; 

• output Lane Change information, by direction, at specified time intervals, for 

specified classes of vehicles; 
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Limitations 

EvolveTraffic is not able to: 

• determine the number of lanes or directions of traffic in the specified input 

traffic file, in advance of the simulation; 

• determine the input traffic file format (whether CASTOR, SAFT or BeDIT); 

• calculate load effects on bridges; 

• model on-ramps, curves in the road or lane closures; 

• model different lengths of lanes or directions; 

• Cars-only lanes cannot yet be modelled. 
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3.3 User Levels 

There will be two main types of user of EvolveTraffic: 

 

Ordinary User 

This type of user is typically interested in running the program to generate new traffic 

configurations. They will be using a set of IDM parameters previously calibrated, but 

may be considering different road layouts. Usually, they will not require the traffic 

metrics detectors output. Indeed once the road layout has been developed, this user 

will probably run the program in Invisible Mode, to get the output traffic file as 

quickly as possible. 

 

Developer User 

This user is using the program to calibrate it against measured real traffic. This user 

will be using the traffic flow metrics detectors in order to compare measured traffic 

properties against the program’s output in order to develop a set of IDM parameters 

that model the measured traffic. This user may also need to change some of the 

program configuration settings in the EvolveTraffic.ini file in order to 

achieve this goal. This user will mostly work in the Visible Mode for visual 

verification of the traffic behaviour, and to use the DataTips to see vehicle 

information during the simulation. 
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4. The EvolveTraffic User Interface 

4.1 Introduction 

The EvolveTraffic program has a Single Document Interface (SDI). This means 

only a single EvolveTraffic file can be opened at any one time – similar to the 

way Notepad in Windows operates. The menu and toolbar commands, whilst being 

specific to the program, are operated in the same way as standard Windows 

programs. 

 

Of note, for ease of use, there is extensive support for keyboard shortcuts in 

EvolveTraffic. This makes it much quicker and easier to use the program 

features during a simulation, whilst in Visible Mode. 
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4.2 Menu 

File 

• File > New:  

Opens a new *.etr file with some default settings. 

• File > Open:  

Displays the Open File dialog for choosing an existing *.etr file. 

• File > Save:  

Saves the current file. 

• File > Save As:  

Allows the current file to be saved as a different name. 

• File > Save Image: 

Saves the view currently visible to a *.bmp file specified in the Save dialog. 

This feature is useful for including configurations in reports/presentations etc. 

and replaces the need for using the Windows Print Screen command. 

• File > Print: 

Prints the current view – this feature is not supported as may be seen from the 

Print Preview command. 

• File > Print Preview: 

Displays a preview of the output that may be sent to the printer. 

• File > Print Setup: 

Specify the setup to be used when printing. 

• File > Recently Used Files: 

A list of recently used files for ease of access. 

• File > Exit: 

Closes the program. 
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Configuration 

• Configuration > Simulation:  

Brings up the Simulation Configuration dialog box – see Section 5. 

• Configuration > Traffic Model:  

Brings up the Traffic Model Configuration dialog box – see Section 5.3. 

• Configuration > Road Features:   

Brings up the Road Features Configuration dialog box – see Section 5.4. 

• Configuration > Traffic Flow Metrics:  

Brings up the Traffic Flow Metrics Configuration dialog box – see Section 5.5. 

• Configuration > User Defined Vehicle:  

Brings up the User Defined Vehicle dialog box – see Section 5.6. 

 

Run 

• Run > As Visible: 

Starts the simulation in the Visible Mode – see Section 6.2. If the simulation is 

currently paused, this restarts the simulation as per Tools > Pause (Resume). 

• Run > As Invisible: 

Starts the simulation in the Invisible Mode – see Section 6.2. 

 

Tools 

• Tools > Zoom In: 

Zooms into the road, making the road and vehicles larger on the screen. 

• Tools > Zoom Out: 

Zooms out from the road, making the road and vehicles smaller on the screen. 

• Tools > Speed Up: 

Speeds the simulation up – the ratio of simulation time to real time increases. 

• Tools > Slow Down: 
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Slows the simulation – the ratio of simulation time to real time reduces. 

• Tools > Pause (Resume): 

Once a simulation is running, this pauses it. If a simulation is paused, this 

command changes to Resume, and resumes the simulation when clicked. 

• Tools > Stop: 

Stops the current simulation. 

• Tools > Mute Detectors: 

Turns on or off all detector output for the next simulation. 

• Tools >Preferences: 

Displays the Preferences dialog – see Section 6.3. 

 

View 

• View > Toolbar: 

Choose whether or not to display the toolbar. 

• View > Status bar 

Choose whether or not to display the status bar at the bottom of the screen, 

which contains the progress bar during the simulation. 

 

Help 

• Help  > About: 

This shows information about the copyright/developers and version of the 

program running. 
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4.3 Toolbar 

 
 

The buttons indicated provide a shortcut to the menu commands as follows: 

• New:  File > New; 

• Open: File > Open; 

• Save: File > Save; 

• Print: File > Print; 

• Simulation: Configuration > Simulation; 

• Traffic: Configuration > Traffic Model; 

• Road Features: Configuration > Road Features; 

• Metrics: Configuration > Traffic Flow Metrics; 

• Run Visible: Run > As Visible; 

• Pause: Tools > Pause (Resume); 

• Stop: Tools > Stop; 

• Run Invisible: Run > As Invisible; 

• Zoom In: Tools > Zoom In; 

• Zoom Out: Tools > Zoom Out; 

• Speed Up: Tools > Speed Up; 

• Slow Down: Tools > Slow Down; 

• Mute Detectors: Tools > Mute Detectors; 

• Preferences: Tools >Preferences; 

New 

Open 

Save Simulation 

Traffic Print 

Road 
Features 

Metrics 

Run  
Visible 

Pause 

Stop 

Run 
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Zoom  
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Zoom 
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• About: Help  > About. 
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4.4 Shortcut Keys 

Extensive support for shortcut keys is included in EvolveTraffic. Some 

commands are only accessible through the keyboard. 

 

Commands only accessibly through the keyboard: 

• Left Arrow: Moves the portion of the road being viewed, one-tenth the length 

of the road to the left; 

• Right Arrow:  Moves the viewport one-tenth of the road length to the right; 

• Home: Moves the viewport to the start of the road; 

• End: Moves the viewport to the end of the road. 

 

In addition to the standard Windows keyboard selection of menu commands, 

EvolveTraffic provides the following keyboard shortcuts to menu commands: 

• Ctrl+N: File > New; 

• Ctrl+O: File > Open; 

• Ctrl+S: File > Save; 

• Ctrl+I: File > Save Image; 

• Ctrl+P: File > Print; 

• Alt+S: Configuration > Simulation; 

• Alt+T: Configuration > Traffic Model; 

• Alt+R: Configuration > Road Features; 

• Alt+M: Configuration > Traffic Flow Metrics; 

• F5: Run > Visible; 

• Shift+F5: Run > As Invisible; 

• F10: Tools > Zoom In; 

• F11: Tools > Zoom Out; 

• F6: Tools > Speed Up; 
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• F7: Tools > Slow Down; 

• F9: Tools > Pause (Resume); 

• F12: Tools > Stop; 

• Alt+P: Tools >Preferences. 
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4.5 Other Interface Elements 

DataTips 

All of the relevant information about a vehicle can be obtain through the DataTips. 

To use these: 

1. A simulation must be running in Visible Mode; 

2. The simulation must be paused; 

3. Clicking on the vehicle of interest with the left mouse button displays the 

DataTip for that vehicle.  

 

The DataTip contains all of the relevant data for that vehicle, as shown: 
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Progress Bar 

The progress bar gives an indication of the amount of simulation complete and 

remaining. At the start of the simulation, EvolveTraffic counts the number of 

vehicles in the input traffic file. At each time step the number of vehicles already read 

from the file is compared to the total number of vehicles to give an estimate of the 

simulation duration, as shown: 

 
 

 
 

Note that once the last vehicle has entered the road the progress bar will display 

100% (since all vehicles have been read), but the simulation is not complete until the 

last vehicle has left the road. 
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Clocks 

For simulations run in both the Visible and Invisible Modes, two clocks are 

maintained: 

• A simulation clock: which represents time as observed by the vehicles; 

• A real clock: representing the elapsed actual time since the start of the 

simulation. 

 
  

In Visible Mode, when paused, the real clock is also paused. This means that at the 

end of the simulation an estimate of the average time warp (ratio of simulation to real 

time) is easily got. 

 

In Invisible Mode, only the final simulation and real times are shown upon 

completion of the simulation. This enables the time warp to be calculated. 

 

Calculation of the time warp can prove useful to examine the effect of including 

various detector output, or even just the detector’s time intervals (Section 5.5). 
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5. EvolveTraffic Input 

5.1 Introduction 

The output from EvolveTraffic is only of use if the input data is representative 

of the traffic stream of interest. Use of the program is therefore an iterative process: 

the Developer User must run the program to get results that may be compared to 

measured traffic statistics and macroscopic properties. Depending on the comparison 

the Developer User must then change some of the traffic configuration properties as 

appropriate and re-run to check on the revised comparison. This process may take 

many iterations. 

 

To minimise effort, all the input data for the program can be saved into 

EvolveTraffic files – file of type *.etr. 

 

Once a traffic stream has been calibrated, that traffic may be run over many different 

road configurations (lengths, speed limits, and gradients). Again a different *.etr 

file may come in useful at this point. Note however, that since the IDM properties 

may be probabilistic (Section 5.3), running the same traffic over the same road 

configuration can result in (slightly) different traffic output files. 

 

All of the above aspects mean that the a calibrated site may be used as the basis for 

many hundreds of different traffic configurations. 

 

 

 

 



EvolveTraffic (v1.2.2)  User Manual, Version 1.2 

© UCD/LCPC 2008 30 

5.2 Simulation Configuration 

This dialog configures the simulation parameters. The various sections of the dialog 

(as shown) are explained as follows: 

 

 
 

Traffic File Details 

• Input Traffic File: The file from which the traffic to be placed on the road is 

read; 

• Output Traffic File: The file to which the traffic is written as it passes the 

output detector; 

• Metrics Directory: The directory to which the metrics detectors output files (if 

any) will be written; 

• Traffic File Format: the format of the file to be read in and written out. Note 

that only CASTOR supports multiple-lane traffic. The SAFT format is for 

single lane traffic. BEDIT, an extended version of the CASTOR format, is 

supported (named for Dr Bernard Enright, DIT). 
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Important! EvolveTraffic does not check the file format prior to reading 

the file. Therefore setting the wrong file format here will result in a program 

crash. 

 

• Number of Lanes: Specify the number of lanes of traffic in each direction, as 

contained in the traffic file. 

 

Important! EvolveTraffic does not check the number of lanes in the 

traffic file prior to reading the file. Therefore setting the wrong numbers here 

may result in a program crash. In particular: 

• Setting more lanes than there are on the traffic file does not affect the 

program execution; 

• Setting fewer lanes than there are in the traffic file results in a program 

crash. 

 

Simulation Details 

• Simulation Step: The time step, in milliseconds, that the simulation progresses 

against. Vehicle driving properties are only updated once per time step. Too 

small a time step is inefficient; too large may result in inaccuracies. For the 

IDM, Treiber uses 250 ms typically, stating that smaller time steps do not 

exhibit significantly different results [3], [4]. 

 

Simulation Road Details 

• Road Length: The length of the road in metres that the vehicles are to be 

driven along. All lanes are this length. 

• Drive on the: Choose the drive-side for the vehicles, European or British-Irish. 

This setting only affects the graphical display of the road and vehicles. 
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• Lane Changes Allowed: Choose whether to allow lane changes or not. 

• Output Cars To File: Specifies whether or not cars are to be output to the 

output traffic file. This is useful for creating truck-only traffic files which are 

of chief interest in bridge loading calculations. 

• Number of Lanes: Specify the number of lanes in each direction on the 

simulation road, up to a maximum of 4. If there is only one direction choose 0 

lanes for the Direction 2 (choosing zero lanes for Direction 1 means the 

program will swap Direction 1 and Direction 2 – single direction roads always 

run in the positive x direction). Note that the user cannot set fewer lanes in the 

simulation road than there are in the input traffic file since the vehicles cannot 

arrive to non-existent lanes. 

• Road Location of Detectors for Output To File: Specify the position of the 

Output Detectors which, upon a vehicle’s arrival, write the vehicle to file along 

with its new time-of-arrival. 

 



EvolveTraffic (v1.2.2)  User Manual, Version 1.2 

© UCD/LCPC 2008 33 

5.3 Traffic Model Configuration 

This dialog configures the IDM parameters that govern the driving behaviour for 

each of the 5 classes of vehicle that the program considers. 

 

 
 

For an explanation of the parameters, refer to Treiber’s work [1], [3]. 

 

Classes of Vehicle 

The program considers 5 classes of vehicle: 

1. Class 0 – Cars: any vehicle under 3.5 tonnes; 

2. Class 1 – Small Trucks: any vehicle with less than 4 axles (i.e. 2- and 3-axle 

vehicles) over 3.5 tonnes; 

3. Class 2 – Large Trucks: any vehicle that is not a car, small truck, crane or 

low-loader; 

4. Class 3 – Crane: any vehicle that is not a car, and has a maximum axle 

spacing of 4.5 m and an average axle spacing less than 2.5 m; 
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5. Class 4 – Low-loader: any vehicle that is not a car and has a maximum axle 

spacing not less than 7.5 m. 

 

EvolveTraffic considers these particular classes of vehicles due to their 

importance in highway bridge traffic loading. 

 

Parameter Values 

For a particular class of vehicle, there are 10 parameters to be set for the IDM and 

MOBIL (lane-changing) models [1], [3]. In all of Treiber’s work to-date these 

parameters have had the same value of each vehicle class he considers. 

EvolveTraffic extends this by allowing vehicles within a class to have varying 

parameters, that is, the program allows probabilistic parameters. However, the 

program retains the ability to specify deterministic (or constant) parameter values. 

 

Each parameter can be distributed according to a number of distributions. Since 

distributions require different numbers of parameters, the most general parameter set 

of location, scale and shape is available. However, setting a parameter (consider 

shape, for example) for a distribution that does not require it (consider the Normal 

distribution, for example), has no effect. It is up to the user to decide upon the 

distribution that best suits the parameter being modelled. The supported distributions, 

with parameters and some comments are: 

1. Exponential: Location and Scale parameters – may be useful for some 

parameters such as Safe Time Headway. Not suitable for most parameters, for 

example, Desired Velocity; 

2. Log-Normal: Location and Scale parameters; 

3. Gamma: Location and Scale parameters; 

4. Gumbel: Location and Scale parameters; 
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5. Poisson: Location and Scale parameters – provides a continuous 

approximation to the discrete distribution only valid when the location 

parameter is greater than 10; 

6. GEV: Location, Scale and Shape parameters – although strictly an extreme 

value distribution, its flexibility (due to its three parameters) allows many 

phenomena to be modelled accurately; 

7. Normal: Location and Scale – the standard Gaussian distribution of parameters 

mean and standard deviation; 

8. Constant: Location – this is the deterministic option as no random numbers 

are generated and the parameter takes the value Location for all vehicles in the 

class. 

 

Important! EvolveTraffic does not check the validity of the distribution values 

entered. It is up to the user to verify that the values and distribution chosen are 

realistic and appropriate both to the distribution and the parameter. Choosing 

inappropriate values or distributions will have unexpected consequences which may 

include the program crashing. 

 

For calibration purposes it is recommended to use Constant parameters initially and 

then use appropriate distributions with increasing values of Scale. This allows the 

impact of the probabilistic parameter values to be assessed. In any case, since most 

parameters cannot be directly measured, the Scale or Shape parameters must be based 

upon judgement and the effect upon the macroscopic traffic statistics. 

 

Defining a Parameter Set 

Choose the Vehicle Class from the drop-down box labelled IDM Parameters for 

Vehicle Class. There are two methods of entering data: 
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1. Using the mouse double click the left button on the cell to edit and type in the 

value.  

2. Use the Tab and the arrow buttons to move between cells. When the 

appropriate cell is selected, typing a value places that value in the cell. 

 

Copying Parameter Sets Between Vehicle Classes 

Since it is likely that most parameter values will be the same between classes, the 

dialog allows the user to copy parameters sets between vehicle classes. For example, 

to copy the parameter set from vehicle Class 2 – Large Truck to Class 3 – Crane: 

1. Be currently defining parameters for vehicle Class 3 – Crane vehicle by 

choosing the Vehicle Class from the drop-down box labelled IDM Parameters 

for Vehicle Class; 

2. In the second (right) drop-down box, select Class 2 – Large Truck; 

3. Press the “<< Copy From <<” button, where the arrows indicate the direction 

in which the copying is taking place. 

 

This is as shown below: 
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5.4 Road Features Configuration 

This dialog allows the user to define the features that a road may have – the so-called 

Road Features. Currently, speed limit and gradient sections of road are available. 

 

 
 

Adding and Deleting Road Features 

To add a Road Feature, press the Add Feature button and then edit the details of the 

newly added feature. To delete a Road Feature, select the appropriate number from 

the drop down list and press the Delete Feature No.: button. 
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The Speed Limit Road Feature 

To include a speed limit section of road, do the following: 

1. Add a Road Feature as above; 

2. Choose Speed Limit from the Type drop-down menu. 

3. Choose the direction that the speed limit is to be applied to from the Direction 

drop-down box. 

4. Input the locations of the start and end of the speed limit section, as measured 

from the start of the road, in the positive x direction. 

5. Type the Value of the speed limit; that is, the actual speed limit in km/h. 

Though up to two decimal places is allowed, this is only enabled for defining 

gradients – speed limits should be integer valued. Non-integer speed limits will 

be rounded by the program. 

 

Notes: 

• EvolveTraffic will exchange the start and end values if it needs to; 
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• There cannot be two speed limits for the same section of road, and so 

EvolveTraffic checks for, and prevents, the user defining overlapping 

speed limit sections, as shown below where the Feature 4 speed limit overlaps 

with the Feature 1 and Feature 2 speed limits, as shown above; 

 

• To prevent unrealistic speed limits, the program checks that the speed limits 

defined are between 10 and 150 km/h; 

 

Effect of a Speed Limit on a Vehicle 

When a vehicle enters a speed limit region the program carries out the following 

steps: 

1. Checks to see if the speed limit is less than the vehicle’s desired velocity, if it 

is it proceeds to the next step; 

2. Stores the desired velocity of the vehicle before it entered the speed limit 

region; 

3. Sets the vehicle a new desired velocity by keeping the ratio of desired velocity 

to speed limit the same as the initial desired velocity to average desired 

velocity (i.e. the Location value of the IDM parameter V0 distribution). 

 

This last step means that vehicles going faster than the average for their class remain 

faster when in the speed limit region and similarly for slower vehicles. 

 

When a vehicle leaves a speed limit region of road, its initial desired velocity is 

restored. Note that a vehicle can enter multiple speed limit regions and still have its 

initial desired velocity restored. 
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The Gradient Road Feature 

To specify a section of road with gradient, follow the steps as per the Speed Limit 

Road Feature. The Value of a Gradient Road Feature is the slope of the road, 

measured as a percentage: 

 

 
 

EvolveTraffic checks that gradient sections of road do not overlap and that the 

maximum slope of 15% is not exceeded. 

 

Effect of a Gradient on a Vehicle 

The EvolveTraffic configuration file has several parameters that specify how a 

gradient affects a vehicle. In Treiber’s work, he models the effect of a gradient by 

reducing the desired velocity [1], [5] only. EvolveTraffic allows the Developer 

User to change more IDM parameters than this, though care must be taken. 

 

Please refer to the comments in the configuration file for further information on how 

a gradient can affect vehicles. 



EvolveTraffic (v1.2.2)  User Manual, Version 1.2 

© UCD/LCPC 2008 41 

5.5 Traffic Flow Metrics Configuration 

This dialog allows the user to define locations on the road where information 

regarding the traffic flow is abstracted: 

 

 
 

To add a detector, select the Add Detector button. To delete a detector, select the 

detector number in the list and then click Delete Detector No. button. For all types of 

detector the following parameters are the same: 

• Type – the type of detector; 

• Direction – the road direction the detector covers; 

• Vehicle Types – the types of vehicles that the detector examines; 

 

Important! Detector location definitions (Parameters A and B) must be made in 

global road coordinates, not local direction coordinates. 

 

The types of detectors available are summed up in the following table: 
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Detector Type Description 

Flow & Density Flow and density at a point detector. Density is estimated using 
the harmonic estimate of space mean speed. 

Headway The time distance between successive vehicles. 

Composition The composition of the traffic detected by vehicle type. 

Lane Changes An over-arching detector of lane changes. 

Output Vehicles The output of vehicles at the detector for further analysis. 

Macro Segment A segment of road recording macroscopic statistics. 

Micro Segment A segment of road recording microscopic statistics. 

S-T Density An array of detectors to output space-time-density information. 

S-T SMS An array of detectors to output space-time-space mean speed 
information. 

 

The remaining parameters for the detectors are as follows: 

 

Detector Type Parameter A Parameter B Parameter C 

Flow & Density Location - - 

Headway Location - - 

Composition Location - - 

Lane Changes Interval - - 

Output Vehicles Location - - 

Macro Segment Start End - 

Micro Segment Start End - 

S-T Density Start Interval End 

S-T SMS Start Interval End 
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Flow & Density 

This detector extracts the flow and density of the traffic as follows: 

• The flow is determined by counting the number of vehicles (of the selected 

type) passing during the time interval. This figure is then changed to the 

standard vehicles per hour measure. 

• The density is determined from the flow per hour (previously found) divided 

by the average velocity of the vehicles during the time interval. That is, 

EvolveTraffic uses the relation: 

 

 Flow Average Velocity Density= ×  

 

The time interval directly affects the calculation of the above properties, and so is of 

importance in the results. Thus, the last two parameters are: 

• Time Interval – the interval (in simulation time) between the detector outputs. 

• Parameter A – this value specifies the location of the detector. 

 

Refer to Section 7.3 for information on the data output by this detector. 
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Headway 

This detector assembles the headway data for the chosen vehicle type(s). 

 

EvolveTraffic considers headway to be the time between two successive 

vehicles, in the same lane, arriving at the detector. 

 

Since EvolveTraffic is run in discrete simulation steps, the time of arrival at the 

detector is based on an interpolation which is based on constant velocity over the 

simulation time-step. 

 

The program records headways calculated in this manner for each lane of the 

specified direction, and for the specified vehicle types. The last two parameters are: 

• Time Interval – the interval (in simulation time) between the detector outputs 

of the recorded data. This value can be reasonably large to avoid the slow 

process of accessing the hard drive. 

• Parameter A – this value specifies the location of the detector. 

 

Refer to Section 7.4 for information on the data output by this detector. 
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Composition 

This detector assembles the composition of the traffic stream at the detector location. 

Since this statistic only makes sense if a range of vehicle types is accounted for, it 

only performs output if the user selects All Vehicles or All Tucks in the Vehicle Type 

drop-down box. 

 

The program outputs the number of each type of vehicle to pass the detector during 

the previous time interval. Thus, the last two parameters are: 

• Time Interval – the interval (in simulation time) between the detector outputs. 

• Parameter A – this value specifies the location of the detector. 

 

Refer to Section 7.5 for information on the data output by this detector. 
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Lane Changes 

This detector assembles Lane Change statistics. A Lane Change Detector takes 

account of lane changes that occur anywhere in the specified road direction and so it 

is only necessary to specify one Lane Change Detector per direction. Specifying more 

Lane Change Detectors will only slow the program’s execution. The last two 

parameters are: 

• Time Interval – the interval (in simulation time) between the detector outputs. 

• Interval – for a Lane Change Detector the ‘Interval’ is the spatial discretization 

required for outputting the lane change rate, as defined by Trieber [3]. This 

value should not be more than 1000 m. 

 

Refer to Section 7.6 for information on the data output by this detector. 
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Output Vehicles 

This detector outputs a vehicle file reporting the arrival time and vehicle information 

at the detector. This enables further detailed assessment of traffic statistics at the 

point, using other software. The last two parameters are: 

• Time Interval – the interval (in simulation time) between the detector outputs. 

• Parameter A – this value specifies the location of the detector. 

 

Refer to Section 7.7 for information on the data output by this detector. 
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Macro Segment 

This detector assembles macroscopic statistics for a road segment, namely the space 

mean speed and density. All vehicles (of the selected vehicle type) on the road 

segment at the time of output contribute to the output statistics. This enables 

comparison between point detector statistics and this ‘snapshot’ type.  

 

The last two parameters are: 

• Time Interval – the interval (in simulation time) between the detector outputs. 

• Parameter A – this value specifies the start of the detector. 

• Parameter B – this value specifies the end of the detector. 

 

Refer to Section 7.8 for information on the data output by this detector. 
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Micro Segment 

This detector assembles microscopic statistics for a road segment, namely relevant 

vehicle information, gap, position and acceleration. All vehicles (of the selected 

vehicle type) on the road segment at the time of output contribute to the output 

statistics. 

 

The last two parameters are: 

• Time Interval – the interval (in simulation time) between the detector outputs. 

• Parameter A – this value specifies the start of the detector. 

• Parameter B – this value specifies the end of the detector. 

 

Refer to Section 7.9 for information on the data output by this detector. 
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S-T Density 

This detector assembles information to prepare a space-time plot of density along the 

road. All vehicles (of the selected vehicle type) on the road segment at the time of 

output contribute to the output statistics. This statistic is useful to observe the 

progression of inhomogeneities in the traffic, and the effect of various obstructions to 

flow.  

 

The last two parameters are: 

• Time Interval – the interval (in simulation time) between the detector outputs. 

• Parameter A – this value specifies the start of the detector array. 

• Parameter B – this value specifies the distance interval for locating the 

intermediate detectors. 

• Parameter C – this value specifies the end location of the detector array. 

 

Refer to Section 7.10 for information on the data output by this detector. 
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S-T SMS 

This detector assembles information to prepare a space-time plot of space mean speed 

along the road. All vehicles (of the selected vehicle type) on the road segment at the 

time of output contribute to the output statistics. This statistic is useful to observe the 

progression of inhomogeneities in the traffic, and the effect of various obstructions to 

flow.  

 

The last two parameters are: 

• Time Interval – the interval (in simulation time) between the detector outputs. 

• Parameter A – this value specifies the start of the detector array. 

• Parameter B – this value specifies the distance interval for locating the 

intermediate detectors. 

• Parameter C – this value specifies the end location of the detector array. 

 

Refer to Section 7.11 for information on the data output by this detector. 
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5.6 User Defined Vehicle Type 

This dialog allows the user to define the parameters that govern the class a vehicle is 

considered to be in. This class takes precedence over all other vehicle types, so care 

must be taken that all vehicles are not assigned to this class, unless that is what is 

intended by the user. 

 

 
 

The parameters specified above mean that no vehicle is assigned to this class, since 

no vehicle will have between 0 and 1 axles (including the inclusive limits 0 and 1 

themselves). Changing the high limit to say 10 axles, will result in all vehicles with a 

number of axles less than or equal to 10 axles being included in the User-Defined 

Vehicle class – for most traffic streams this will be the vast majority of vehicles. 

 

By defining a vehicle type, the user can specify driver parameters for those vehicles, 

as well as restrict detector output to this vehicle type. This enables the user to have 

control over the exact subset of the traffic stream that is of interest. 



EvolveTraffic (v1.2.2)  User Manual, Version 1.2 

© UCD/LCPC 2008 53 

6. Running EvolveTraffic 

6.1 Introduction 

The usual procedure followed when using the program is: 

1. Define the input data either by using the dialogs (Section 5) or by opening an 

*.etr file (Section 5.1); 

2. Run the program in Visible Mode (Section 6.2) to view the behaviour of the 

traffic (Section 4) and to obtain intermediate information (Section 4.5); 

3. Examine the various detector output files using a *.csv file viewer, such as 

MS Excel. 

 

The user preferences and configuration preferences required for the program are 

explained next. 
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6.2 Simulation Modes 

Introduction 

Two modes of running the simulations are provided to meet the aims of the program. 

 

Visible Mode 

In this mode, the user can interact with the program at any stage of the simulation and 

change visualisation parameters via the User Preferences dialog box (Section 6.3). 

This mode displays the vehicles as they progress along the road. The animation can 

be paused or stopped at any time. Whilst paused, information on vehicles can be got 

though the DataTips (Section 4.5). Also, at any point during the simulation, a 

screenshot of the simulation may be taken using the File > Save Image command (or 

the Ctrl+I keyboard shortcut). These features make the Visible Mode an interactive 

environment for the calibration of a traffic model. 

 

The features described for Visible Mode above come at the expense of execution 

time. Both rendering the simulation to the screen at 20 frames per second, and 

interrupting the simulation every time the user interacts with the program, mean that 

results cannot be obtained as fast as possible. Further, this mode requires that the 

program ‘sleep’ for a period during each simulation step in order that the animation 

of vehicles is done at a slow enough speed for human eyes to perceive. Invisible 

Mode rectifies these issues as it is optimised for speed of execution. 
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Invisible Mode 

When a simulation is run in invisible mode the program does the following: 

1. Runs the simulation as fast as possible; 

2. Updates the timer in the main window. 

The timer updating is therefore the only indication the user has that the program is 

running. This mode can run very fast with simulation time to real time ratios of over 

5000 achieved (but this depends on road feature complexity, traffic, lane changes, 

detector output etc.). 

 

When running in Invisible Mode, the program operates with two processing threads, 

to maintain GUI responsiveness. However, the two threads still form part of the one 

process and so minimal use of the user interface is preferable for maximum speeds. 

Optimally, consider covering the EvolveTraffic window so that the processing 

is not slowed down by window redraws. 

 

Users with single-core processers may not be able to use other programs and the 

computer may appear frozen until the simulation is complete. For such users, to 

optimise simulation times, it is advised that no other programs be running at the same 

time. 
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6.3 Program Preferences 

Ordinary User Preferences 

User preferences can be specified though the User Preferences dialog, shown here: 

 

 
 

The parameters are: 

• Overall Scale: the current scale of the drawing; 

• Widths Scale: the exaggeration applied to the road and vehicle widths so that 

it is easier to visualize the vehicles; 

• Time Warp Factor: the ratio between simulation time and real time; 

• Lane Width: the width of a lane as drawn prior to application of the Widths 

Scale factor; 

• Vehicle Width: the width of a vehicle as drawn prior to application of the 

widths scale factor; 
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• Vehicle Length Scale: a factor that allows the length of a vehicle to be 

exaggerated in order that a more reasonable aspect ration is kept once the 

Widths Scale factor has been applied. Note that when this is not unity it can 

appear that vehicles overlap on the road when very close (bumper-to-bumper 

traffic), set this to unity to observe that this is not the case. Note also that the 

vehicle length is exaggerated from the front of the vehicle, that is, the extra 

length is applied to the back of the vehicle always. 

• Show Velocities: set this value to zero to turn off (any other value turns it on) 

the display of the velocities of each vehicle (shown as a text output overlaid): 

 

 
• Show Legend: set this value to zero to turn off (any other value turns it on) the 

display of the legend at the top of the screen: 

 

 
 

• Tick Length: the length of the ruler ticks; 

• Tick Interval: the interval between ruler ticks and distance displays; 
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• Border Top: the border between the top of the screen and the legend and 

clocks; 

• Border Bottom: currently obsolete; 

• Border Left: the border between the start of the road and the edge of the 

window; 

• Border Right: the border between the end of the road and the edge of the 

window. 
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Developer User Preferences 

These are as specified in the EvolveTraffic.ini configuration file found in the 

program folder. Refer to Appendix 9.1 for the default version of this file, and for the 

extensive explanatory comments. 

 

Note that the user can add their own comments (similar to C++ style single line 

comments) to this file by preceding the line with two forward slashes: //.  

 

Some of the configuration parameters may be brought into the main interface in 

future versions for ease of use. 
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6.4 Examples 

Included with the installation are three example applications of EvolveTraffic in 

the Examples folder of the program installation folder. Open the relevant *.etr file 

and run in Visible Mode to see the examples, or in Invisible Mode to get straight to 

the detector output. 

 

Example 1 – Ex 1.etr 

This example represents a congested truck-only traffic file, run on a road of 5 km 

length, with several speed limit and gradient regions: 

 

 
 

Lane change detectors are specified for both directions. 

 

In this file, congestion can be seen to start occurring in each direction at the first 

Road Feature the vehicles arrive at. High levels of lane changes occur at this point, as 

may be observed in the Lane Change Detector Output. 
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Example 2 – Ex 2.etr 

This example illustrates a free-flowing truck-only traffic file, run on the same road as 

Example 1. Various detectors are specified along the length of the positive direction: 

 

 
 

 

Example 3 – Ex 3.etr 

This file illustrates a SAFT input file from the RN4 in France. A speed limit section 

of 50 km/h is specified for 500 m along the 3 km road: 
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7. EvolveTraffic Output 

7.1 Introduction 

EvolveTraffic has the ability to produce large amounts of output, especially for 

long or heavily congested traffic files. The program accesses the hard drive at every 

time interval specified for each detector (Section 5.5) and this can significantly slow 

the program’s execution. Therefore it is recommended that statistical detector output 

is only used when required for calibrating the IDM traffic parameters. For execution 

of the program for the sole purpose of obtaining another randomized traffic file, 

based on calibrated IDM parameters, it is better to have no detector output. 

 

For calibration purposes, the statistical detectors’ output is comprehensive and should 

be sufficient to obtain good matches between measured and simulated traffic. This 

process is not trivial – only macroscopic statistics can be used as the basis for 

comparison of measured against simulated traffic. 

 

Besides the output traffic file, all detector output files are in Comma-Separated 

Values (*.csv) file format which can be read by any spreadsheet viewer, such as 

MS Excel. They are output to the directory as specified by the user in the Simulation 

Configuration dialog (Section 5.2). 
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7.2 Traffic File 

For every simulation run, each vehicle is output to file at the time it hits the location 

of the Output Detector (Section 5.2) for its direction. The physical properties of the 

vehicle are maintained through the simulation, and these are written out to file and 

will be the same as those read in. The arrival time at the Output Detector is output to 

this file as the vehicle’s new time stamp. It is this time stamp that is the reason behind 

EvolveTraffic, since it represents the driving behaviour as the vehicle moves 

along the road. 

 

The output traffic file is in the same format as the input traffic file (Section 5.2). For 

reference, the CASTOR and SAFT file formats are given. 

 

The output traffic file is saved with the name, extension and location as specified by 

the user in the Simulation Configuration dialog (Section 5.2). 
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7.3 Flow & Density 

File 

The output for a Flow Density Detector is made to the following file: 

 

FD_vvv_ddd_xxxx.csv 

 

Where: 

• FD – means Flow Density detector file; 

• vvv – the vehicle type for which the output is made, it can be: 

o All – for All Vehicles output; 

o Trucks – For all trucks output; 

o Car – for Car only output; 

o ST – for Small Truck only output; 

o LT – for Large Truck only output; 

o Crane – for Crane only output; 

o LL – for Low-loader only output; 

• ddd – the direction identifier: 

o Pos – for the positive x direction; 

o Neg – for the negative x direction; 

• xxxxx – a number representing the location of the detector in metres. 
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Output 

The format of the Flow Density output is: 

 

• The first column, contains an index representing the time interval for which the 

output was made; 

 

Next, for each lane in the direction that the detector considers, for the particular time 

interval considered, we have four columns: 

• Density (veh/km) – the measured traffic density of the vehicles considered; 

• Flow (veh/hr) – the flow of the vehicles considered; 

• Space Mean Speed (km/h) – the harmonic average velocity of the vehicles 

considered; 

• Time Mean Speed (km/h) – the average velocity noted over the time interval 

considered. 

 

Finally, for the direction as a whole, we have the four columns of Density, Flow and 

speeds as before. 

 

An example output for a two-lane direction is: 
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7.4 Headway 

File 

The output for a Headway Detector is made to the following file: 

 

Head_vvv_ddd_xxxx.csv 

 

In which vvv, ddd, and xxxx have the same meanings as for the Flow Density 

Detector file (Section 7.3). 

 

Output 

At each time interval, EvolveTraffic outputs the vectors 

of headways (in seconds), for the vehicle types considered, for 

each lane for the direction which the detector covers. An 

example is shown to the left. 

 

Note from the example that the first vehicles have large 

headways (since there is no vehicle in front). Also notice that 

Lane 1 is more heavily trafficked than Lane 2. 
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7.5 Composition 

File 

The output for a Composition Detector is made to the following file: 

 

Comp_vvv_ddd_xxxx.csv 

 

In which vvv, ddd, and xxxx have the same meanings as for the Flow Density 

Detector file (Section 7.3). 

 

Output 

The output for each time interval is simply the count of the number of vehicles of the 

vehicle type that passed the detector during the previous time interval. Each time 

interval writes to a row and each vehicle type has a column. All best seen in the 

example output (taken from a traffic file without cars): 
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7.6 Lane Changes 

File 

The output for a Lane Change Detector is made up of the following files: 

 

1. LC_All_vvv_ddd.csv; 

2. LC_Comp_vvv_ddd.csv; 

3. LC_Rate_vvv_ddd.csv; 

4. LC_ST_vvv_ddd.csv; 

 

In which vvv, and ddd have the same meanings as for the Flow Density Detector 

file (Section 7.3). 

 

The LC_All File 

This file outputs the raw information relating to lane change events. The format of the 

file is best seen by example: 

 

 
 

The columns are explained as: 
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• Time: the time at which the lane change vene took place; 

• Position: the location (as measured from the start of the road) of the lane 

change; 

• From Lane: the lane number that the vehicle moved from; 

• To Lane: the lane number that the vehicle moved to; 

• Right/Left: whether the vehicle moved left or right; 

• Type: the vehicle type that changed lane. 

 

Note that lanes are numbered from the outside lane of the positive x direction to the 

outside lane of the negative x direction. So for a European road: 

 

 
 

And for a left-hand drive roads: 

 

 

Lane 1 

Lane 2 

Lane 3 

Lane 4 

Direction of travel 

Lane 4 

Lane 3 

Lane 2 

Lane 1 

Direction of travel 
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The LC_Comp File 

This file gives information pertaining to the composition of lane change events by 

vehicle type. Since this output only makes sense if the vehicle type for this detector is 

All Vehicles, no output is performed for other vehicle types. 

 

An example of this file’s output for a traffic stream with no cars is: 

 

 
 

The number of lane changes that occurred in the previous time interval of each 

vehicle type is as indicated. 
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The LC_Rate File 

This file contains the lane change rate for each time interval for each ‘Step’ (see 

Section 5.5) along the road length. This metric is as defined in the paper on the lane 

change model, MOBIL [3]. The lane change rate is: 

 

 ( ), , LCnr x t
t x

ρ =
∆ ⋅∆

 

 

In which: 

• ( ), ,r x tρ  is the lane change rate, and is a function of both time, distance and 

traffic density; 

• LCn  is the number of lane changes that occurred in the time interval, t∆ ; 

•  and t x∆ ∆  are the temporal and spatial discretizations. 

The lane change rate is measure in units of number of lane changes per hour per 

kilometre (1/hr/km). Taking  1 min.t∆ =  and 200 mx∆ = , a single lane change is 

equivalent to a lane change rate of: 

 

 
( )( )

1 300 /hr/km
1 60 200 1000

=  

 

Therefore the lane change rate values in the file will tend to be round numbers due ot 

the above calculations. Further, this metric is calculated for each time interval at each 

step along the road, leading to a large matrix of lane change rates. An example is: 
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Note that in this example the columns referring to Steps 1600 m to 4400 m have been 

hidden.  

 

From this example it is apparent that there is significant lane changing at 1000 m. 

This is caused by a speed limit section that starts at this point in the road. 

 

By keeping the Lane Change Detector time interval the same as that of the Flow 

Density Detector, the lane change rates and density at a particular point on the road 

can be plotted together. As explained in the MOBIL paper [3], this curve should 

display low rates of lane changing at low flows, high rates at medium flows and low 

rates at fully congested flows. 
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The LC_ST File 

This file outputs the time and position of each lane change event for both Left to 

Right changes, and for Right to Left changes, for the direction that the detector is 

applied to. An example is: 

 

 
 

The plot that results from a large amount of such data can be very informative: 
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Noting that each change is represented by a point, this plot shows that a large number 

of lane change events occur at about 1000 m and as time progresses this point moves 

backwards towards the start of the road (at 0 m). This is explained by the presence of 

the speed limit region previously mentioned (and as shown below), that causes 

congestion that progresses backwards, necessitating earlier lane changes. Further 

along the road (beyond say 2000 m) there are a number of vehicles returning to the 

outside lane, and very few overtaking events. 
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7.7 Output Vehicles 

File 

The output for an Output Vehicles Detector is made to the following file: 

 

Veh_vvv_ddd_xxxx.txt 

 

In which vvv, ddd, and xxxx have the same meanings as for the Flow Density 

Detector file (Section 7.3). 

 

Output 

The vehicles are output as per the regular Output Detectors in the same file format 

(CASTOR, SAFT, or BEDIT) as the input traffic file. 
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7.8 Macro Segment 

File 

The output for a Macro Segment Detector is made to the following file: 

 

Macro_vvv_ddd_xxxx.csv 

 

In which vvv, ddd, and xxxx have the same meanings as for the Flow Density 

Detector file (Section 7.3). 

 

Output 

The output for each time interval is the exact density and space mean speed on the 

road segment at the instant of output. This information is given for each lane, as well 

as the total for the direction. An example output is below: 
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7.9 Micro Segment 

File 

The output for a Micro Segment Detector is made to the following file: 

 

Micro_vvv_ddd_xxxx.csv 

 

In which vvv, ddd, and xxxx have the same meanings as for the Flow Density 

Detector file (Section 7.3). 

 

Output 

The output for each time interval is made for each vehicle as per the example output 

below. As an example of this output’s usefulness, by sorting on the vehicle ID 

column, a vehicle’s trajectory over the course of the segment can be determined 

(once the time interval is not so great that the vehicle has left the road segment).  

 

The Vehicle ID is assigned as the order of appearance in the input traffic file. The 

class number is given as a zero-based index of the vehicle types supported (see 

Section XX). The Position given is the local lane coordinate. 
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7.10 S-T Density 

File 

The output for a Space-Time Density Detector is made to the following file: 

 

STD_vvv_ddd_xxxx.csv 

 

In which vvv, ddd, and xxxx have the same meanings as for the Flow Density 

Detector file (Section 7.3). 

 

Output 

The output for each time interval is a density estimate (based on the harmonic 

estimate of space mean speed) at each detector point in the array (distributed along 

the road according to the start-interval-end parameters). The output is formatted in 

such a way that three-dimensional plotting is easily facilitated. For each lane of the 

direction, and for the total in the direction, the density at for each time interval is 

given on a row under a column corresponding to the location of each detector, as 

shown in the example: 
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7.11 S-T SMS 

File 

The output for a Space-Time Space Mean Speed Detector is made to the following 

file: 

 

STSMS_vvv_ddd_xxxx.csv 

 

In which vvv, ddd, and xxxx have the same meanings as for the Flow Density 

Detector file (Section 7.3). 

 

Output 

The output for each time interval is a space mean speed estimate (based on the 

harmonic estimate) at each detector point in the array (distributed along the road 

according to the start-interval-end parameters). The output is formatted similar to the 

S-T Density output. 
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8. FAQs and TroubleShooting 

8.1 FAQs 

Since this is the first release of this program there are no frequently asked questions! 
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8.2 TroubleShooting 

As this is the first release of this program there bound to be some bugs and 

inconsistent behavior. Please check below for some possible solutions. If the problem 

persists, please send a copy of the *.etr and input traffic file that causes the 

problem to colin.caprani@dit.ie explaining the steps required to reproduce the 

problem. 

 

It is envisaged that this section of the document will be updated frequently as the 

program matures. 

 

Problems  

The program crashes 

• Please check this document for the Important! labels and confirm that you 

have adhered to these requirements. 

• Restore the default configuration file values if you have changed any. 

 

The driving is not realistic 

• Check the IDM parameters for realism; 

• Use Treiber’s IDM parameters ([1], [3]) with a small traffic file to verify 

realism; 

• Slowly build the extra complexity into the IDM parameters, verifying the 

realism at each stage. 

mailto:colin.caprani@dit.ie
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9. Appendices 

9.1 Appendix 1 – CASTOR and SAFT File Formats 

CASTOR File Format  

In the table below, the Format column gives the storage type of the data.  IX refers to 

an integer of X number of digits, including leading or trailing zeros. 

 

Record Unit Format 
Head  I4 
Day  I2 
Month  I2 
Year  I2 
Hour  I2 
Minute  I2 
Second  I2 
Second/100  I2 
Speed dm/s I3 
Gross Vehicle Weight - GVW kg/100 I4 
Length dm I3 
Number of Axles  I1 
Direction  I1 
Lane  I1 
Transverse Location In Lane dm I3 
Weight Axle 1 kg/100 I3 
Spacing Axle 1 - Axle 2 dm I2 
Weight Axle 2 kg/100 I3 
Spacing Axle 2 - Axle 3 dm I2 

      
Spacing Axle 8 - Axle 9 dm I2 
Weight Axle 9 kg/100 I3 



EvolveTraffic (v1.2.2)  User Manual, Version 1.2 

© UCD/LCPC 2008 84 

SAFT File Format 

As for the CASTOR table, the Format column gives the storage type of the data.  IX 

refers to an integer of X number of digits, including leading or trailing zeros. Note 

that since the SAFT format does not contain direction or lane identifiers, this format 

is suitable for single lane traffic only. 

 

Record Unit Format 

Vehicle order  I5 

20000 unused number  I5 

Day  I2 

Month  I2 

Year  I2 

Hour  I2 

Minute  I2 

Second  I2 

Second/100  I2 

Speed dm/s I3 

Gross Vehicle Weight - GVW kN I4 

Length dm I3 

Number of Axles  I1 

Weight Axle 1 kN I3 

Spacing Axle 1 - Axle 2 dm I2 

      

Spacing Axle 8 – Axle 9 dm I3 

Weight Axle 9 kN I2 
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BeDIT File Format  

This file format is similar to CASTOR except that the maximum number of axles 

possible is 20, the axle spacings are given by a three digit number, and the direction 

is zero-based. 

 

Record Unit Format 
Head  I4 
Day  I2 
Month  I2 
Year  I2 
Hour  I2 
Minute  I2 
Second  I2 
Second/100  I2 
Speed dm/s I3 
Gross Vehicle Weight - GVW kg/100 I4 
Length dm I3 
Number of Axles  I1 
Direction (zero-based)  I1 
Lane  I1 
Transverse Location In Lane dm I3 
Weight Axle 1 kg/100 I3 
Spacing Axle 1 - Axle 2 dm I3 
Weight Axle 2 kg/100 I3 
Spacing Axle 2 - Axle 3 dm I3 

      
Spacing Axle 19 - Axle 20 dm I3 
Weight Axle 20 kg/100 I3 
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9.2 Appendix 2 – Further Documentation  

The source code documentation gives further detailed information on the algorithms 

used in the program, along with explanations of the source code structure. An 

example output below illustrates the Detector Classes hierarchy. The source code 

documentation is included in the installation package. To open: 

In the program’s installation folder, open the \Documents\html\ folder and 

double click on the index.html file. Alternatively, you can view a PDF of 

the documentation in the \Documents\ folder: SourceDoc.pdf. 
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9.3 Appendix 3 - EvolveTraffic.ini Configuration File 
//-------------------------------------------------------------------- 
//------------- EVOLVETRAFFIC PROGRAM CONFIGURATION FILE ------------- 
//--------------------------- VERSION 1.2 ---------------------------- 
//-------------------------------------------------------------------- 
//  
// Notes: 
// 1. This file is used by EvolveTraffic to set environment variables 
//    that may be altered by the user. 
// 2. Before altering this file make a back up copy - even though the  
//    default values for each parameter are given in the description. 
// 3. The user can insert their own comments in this file, once they 
//    are preceded by "//". 
// 4. No checking of the validity of this file is done by the program. 
//    If, after a change to this file, the program does not run, or 
//    exhibits strange behaviour, please use your back up. 
// 5. You can email colin.caprani@ucd.ie with any questions, or for 
//    a copy of the default file, to save reinstallation. 
// 6. This file is in a format particular to EvolveTraffic and is not 
//    in standard *.ini format. 
// 7. Do NOT alter the sequence of the variables - the program assumes 
//    the sequence as given below. 
// 
//-------------------------------------------------------------------- 
// 
// 
//-------------------------------------------------------------------- 
// IDM - General parameters for the IDM microsimulation model 
//-------------------------------------------------------------------- 
// Please refer to Treiber's references for more information on these 
// parameters. 
// 
// IDM.LANECHANGE_MIN_GAP = 2.0; 
//-------------------------------------------------------------------- 
// The minimum gap to the rear of the vehicle in front, in the target 
// lane, or from the front of the rear vehicle in the target lane, to 
// the rear of the current vehicle. 
// A lane change is not considered if both these gaps are not larger 
// than this parameter specifies. 
// UNITS: m 
// NUMBER TYPE: real 
// VALUE: 
2.0 
// 
// IDM.MIN_SPACE_FOR_NEXT_VEHICLE = 27.0; 
//-------------------------------------------------------------------- 
// The minimum clear space in front of the next vehicle to enter the  
// road, before it is allowed onto the road. 
// UNITS: m 
// NUMBER TYPE: real 
// VALUE: 
27.0 
// 
// IDM.SAFE_BRAKING = -12.0; 
//-------------------------------------------------------------------- 
// The maximum permissible deceleration any vehicle can undergo. 
// This number provides a check on the realism of the random braking 
// ability generated according to the user-defined IDM parameters. 



EvolveTraffic (v1.2.2)  User Manual, Version 1.2 

© UCD/LCPC 2008 88 

// UNITS: m/s^2 
// NUMBER TYPE: real - always negative 
// VALUE: 
-12.0 
// 
// IDM.T_DELAY = 1.6; 
//-------------------------------------------------------------------- 
// This specifies the time gap between consideration of lane change  
// events for a particular vehicle. Once a lane change event has  
// occurred for this vehicle, the timer is reset and a subsequent 
// lane change can only occur once the specified time delay has been 
// passed. 
// UNITS: s 
// NUMBER TYPE: real 
// VALUE: 
1.6 
// 
//-------------------------------------------------------------------- 
// 
// 
//-------------------------------------------------------------------- 
// ROAD - Parameters affecting the road and its contents 
//-------------------------------------------------------------------- 
// 
// Road.ROAD_END_BUFFER = 1000; 
//-------------------------------------------------------------------- 
// This is the distance that the front vehicle in any lane considers 
// as being clear road (no vehicles) in front of them, even as it 
// approaches the end of the defined road length. This means that 
// vehicles approach the end of the road realistically. 
// UNITS: m 
// NUMBER TYPE: integer 
// VALUE: 
1000 
// 
// Road.RoadFeatures.SpeedLimit.SPEEDLIMIT_MIN = 10; 
//-------------------------------------------------------------------- 
// This is the minimum permissible speed limit that the user can  
// specify. Included to keep things more realistic. 
// This must be greater than zero. 
// UNITS: km/h 
// NUMBER TYPE: integer 
// VALUE: 
10 
// 
// Road.RoadFeatures.SpeedLimit.SPEEDLIMIT_MAX = 150; 
//-------------------------------------------------------------------- 
// This is the maximum permissible speed limit that the user can  
// specify. Included to keep things more realistic. 
// UNITS: km/h 
// NUMBER TYPE: integer 
// VALUE: 
150 
// 
// Road.RoadFeatures.Gradient.MAX_SLOPE = 15; 
//-------------------------------------------------------------------- 
// This is the maximum permissible slope of gradient that the user can  
// specify. Included to keep things more realistic, and to conform 
// better with the assumptions made in modifying the vehicles' driver 
// model. 
// UNITS: % 
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// NUMBER TYPE: integer 
// VALUE: 
15 
// 
// Road.RoadFeatures.Gradient.IDM_Modifiers.A_FLAG = true; 
//-------------------------------------------------------------------- 
// This flag specifies if a vehicles acceleration ability is to be 
// be modified to account for the gradient it is on. 
// Included because Treiber does not do this, but basic physics 
// suggests that a vehicles acceleration ability is lessened. 
// This ability is not modified for downhill gradients. 
// UNITS: N/A 
// NUMBER TYPE: boolean (use 1 or 0) 
// VALUE: 
1 
// 
// Road.RoadFeatures.Gradient.IDM_Modifiers.A_MIN = 0.1; 
//-------------------------------------------------------------------- 
// The minimum acceleration ability that any vehicle can have after 
// having its ability modified to take account of a gradient it may 
// be on. 
// This number must be greater than zero. The program will crash due to 
// a divide by zero, or a square root of a negative number if it is not. 
// UNITS: N/A 
// NUMBER TYPE: real 
// VALUE: 
0.1 
// 
// Road.RoadFeatures.Gradient.IDM_Modifiers.B_FLAG = true; 
//-------------------------------------------------------------------- 
// This flag specifies if a vehicles braking ability is to be 
// be modified to account for the gradient it is on. 
// Included because Treiber does not do this, but basic physics 
// suggests that a vehicle can brake easier going uphill. 
// This ability is not modified for downhill gradients. 
// UNITS: N/A 
// NUMBER TYPE: boolean (use 1 or 0) 
// VALUE: 
1 
// 
// Road.RoadFeatures.Gradient.IDM_Modifiers.T_SLOPE = 10.0; 
//-------------------------------------------------------------------- 
// This specifies how the IDM parameter, T, the safe time headway, 
// changes according to the gradient the vehicle is on. This value is 
// the number of percent of gradient, per second increase in the safe  
// time headway. 
// It is increased for the gradient, whether uphill or downhill. 
// UNITS: %/s 
// NUMBER TYPE: real 
// VALUE: 
10.0 
// 
// Road.RoadFeatures.Gradient.IDM_Modifiers.V0_MIN = 3.0; 
//-------------------------------------------------------------------- 
// This specifies the minimum desired velocity any vehicle can have  
// after its desired velocity has been modified to account for the  
// gradient the vehicle is on.  
// THis number must be greater than zero, since every vehicle should  
// want to make progress. 
// UNITS: m/s 
// NUMBER TYPE: real 
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// VALUE: 
3.0 
// 
// Road.RoadFeatures.Gradient.IDM_Modifiers.V0_SLOPE = 0.2; 
//-------------------------------------------------------------------- 
// This specifies how the IDM parameter, V0, the desired velocity,  
// varies with gradient. It is measured in the % gradient per 1 km/h 
// reduction in the desired velocity. 
// The desired velocity is reduced for downhill gradients and not  
// modified for uphill gradients. 
// UNITS:  
// NUMBER TYPE: integer 
// VALUE: 
0.2 
// 
//-------------------------------------------------------------------- 
// 
// 
//-------------------------------------------------------------------- 
// TIME - Parameters defining the time output of the vehicles 
//-------------------------------------------------------------------- 
// Since we usually consider there to be 5 working days per week for  
// 50 weeks per year - which allows for holidays - we have 250 days 
// per year. We thus consider there to be 10 working "months" per year 
// of 25 working "days" each. 
// A vehicle with a time stamp of 3 500 000 seconds thus is written  
// out to file as: 10/02/08 12:13.20 
// 
// Time.DAYS_PER_MT = 25; 
//-------------------------------------------------------------------- 
// The number of days per simulation month. 
// UNITS: N/A 
// NUMBER TYPE: integer 
// VALUE: 
25 
// 
// Time.MTS_PER_YR = 10; 
//-------------------------------------------------------------------- 
// The number of simulation months per year. 
// UNITS: N/A 
// NUMBER TYPE: integer 
// VALUE: 
10 
// 
//-------------------------------------------------------------------- 
// 
// 
//-------------------------------------------------------------------- 
// VEHICLEID - Parameters defining the identification of vehicles 
//-------------------------------------------------------------------- 
// The program defines 5 types of vehicles, and these parameters  
// govern the vehicle class assigned to a vehicle. 
// 
// VehicleID.CRANE_AVERAGE_SPACING = 2.5; 
//-------------------------------------------------------------------- 
// The average spacing of a crane's axles. 
// UNITS: m 
// NUMBER TYPE: real 
// VALUE: 
2.5 
// 
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// VehicleID.CRANE_MAX_SPACING = 4.5; 
//-------------------------------------------------------------------- 
// The maximum single axle spacing possible for a vehicle to still be 
// considered a crane. 
// UNITS: m 
// NUMBER TYPE: real 
// VALUE: 
4.5 
// 
// VehicleID.LOWLOADER_MIN_MAX_SPACING = 7.5; 
//-------------------------------------------------------------------- 
// If a vehicle has a maximum axle spacing greater than this value,  
// and has more than 2 axles, it is considered a low-loader. 
// UNITS: m 
// NUMBER TYPE: real 
// VALUE: 
7.5 
// 
// VehicleID.SMALL_TRUCK_NO_AXLES = 3; 
//-------------------------------------------------------------------- 
// The maximum number of axles a small truck can be considered to  
// have. 
// UNITS: N/A 
// NUMBER TYPE: integer 
// VALUE: 
3 
// 
// VehicleID.TRUCK_WEIGHT_THRESHOLD = 35; 
//-------------------------------------------------------------------- 
// A vehicle with a weight less than this value is a car, otherwise 
// it is a truck. 
// UNITS: kg/100 
// NUMBER TYPE: integer 
// VALUE: 
35 
// 
//-------------------------------------------------------------------- 
// 
// 
//-------------------------------------------------------------------- 
// VIEW - Parameters governing the screen display. 
//-------------------------------------------------------------------- 
// 
// View.MIN_VIEW_SCALE = 0.1; 
//-------------------------------------------------------------------- 
// The minimum value the user can zoom out to. Setting this value too 
// low will result in the program crashing. 
// UNITS: N/A 
// NUMBER TYPE: real 
// VALUE: 
0.1 
// 
// View.DATATIP_DELAY = 20.0; 
//-------------------------------------------------------------------- 
// The time in seconds that the vehicle datatip stays visible after 
// the user clicks on a vehicle in pause mode. Must be greater than  
// zero or program will crash. 
// UNITS: N/A 
// NUMBER TYPE: real 
// VALUE: 
20.0 
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// 
// View.TIMEWARP_SIMSTEP = 10; 
//-------------------------------------------------------------------- 
// The time in milliseconds (simulation timestep divided by the  
// timewarp) that if the delay between simulation steps is less than,  
// then accelerated timewarp is used. This only applies in visible  
// mode. Higher values of this will cause the vehicles to appear  
// jumpy on screen at lower timewarps. Must be greater than  
// zero or the program will crash. 
// UNITS: ms 
// NUMBER TYPE: integer 
// VALUE: 
10 
// 
// View.Colours.Vehicles.VEH_COLOR_CAR = RGB(0,0,0); 
//-------------------------------------------------------------------- 
// The display colour for a car. 
// UNITS: RGB( 0 to 255, 0 to 255, 0 to 255 ) 
// NUMBER TYPE: integer, integer, integer 
// VALUE: 
0,0,0 
// 
// View.Colours.Vehicles.VEH_COLOR_SMALLTRUCK = RGB(0,0,255); 
//-------------------------------------------------------------------- 
// The display colour for a small truck. 
// UNITS: RGB( 0 to 255, 0 to 255, 0 to 255 ) 
// NUMBER TYPE: integer, integer, integer 
// VALUE: 
0,0,255 
// 
// View.Colours.Vehicles.VEH_COLOR_LARGETRUCK = RGB(255,0,0); 
//-------------------------------------------------------------------- 
// The display colour for a large truck. 
// UNITS: RGB( 0 to 255, 0 to 255, 0 to 255 ) 
// NUMBER TYPE: integer, integer, integer 
// VALUE: 
255,0,0 
// 
// View.Colours.Vehicles.VEH_COLOR_CRANE = RGB(0,255,0); 
//-------------------------------------------------------------------- 
// The display colour for a crane. 
// UNITS: RGB( 0 to 255, 0 to 255, 0 to 255 ) 
// NUMBER TYPE: integer, integer, integer 
// VALUE: 
0,255,0 
// 
// View.Colours.Vehicles.VEH_COLOR_LOWLOADER = RGB(100,100,100); 
//-------------------------------------------------------------------- 
// The display colour for a low-loader. 
// UNITS: RGB( 0 to 255, 0 to 255, 0 to 255 ) 
// NUMBER TYPE: integer, integer, integer 
// VALUE: 
100,100,100 
// 
// View.Colours.Vehicles.VEH_COLOR_USERDEF = RGB(138,43,226); 
//-------------------------------------------------------------------- 
// The display colour for a low-loader. 
// UNITS: RGB( 0 to 255, 0 to 255, 0 to 255 ) 
// NUMBER TYPE: integer, integer, integer 
// VALUE: 
138,43,226 
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// 
// View.Colours.DrawElements.CLR_BACKGRND = RGB(255,255,255); 
//-------------------------------------------------------------------- 
// The display colour for the background - usually white. 
// UNITS: RGB( 0 to 255, 0 to 255, 0 to 255 ) 
// NUMBER TYPE: integer, integer, integer 
// VALUE: 
255,255,255 
// 
// View.Colours.DrawElements.CLR_ROAD_SURFACE = RGB(200,200,200); 
//-------------------------------------------------------------------- 
// The display colour for the road surface. 
// UNITS: RGB( 0 to 255, 0 to 255, 0 to 255 ) 
// NUMBER TYPE: integer, integer, integer 
// VALUE: 
200,200,200 
// 
//View.Colours.DrawElements.CLR_ROAD_LINES = RGB(0,0,0); 
//-------------------------------------------------------------------- 
// The display colour for the road line markings. 
// UNITS: RGB( 0 to 255, 0 to 255, 0 to 255 ) 
// NUMBER TYPE: integer, integer, integer 
// VALUE: 
0,0,0 
// 
//View.Colours.DrawElements.CLR_RULER_LINES = RGB(0,0,0); 
//-------------------------------------------------------------------- 
// The display colour for the ruler tick lines. 
// UNITS: RGB( 0 to 255, 0 to 255, 0 to 255 ) 
// NUMBER TYPE: integer, integer, integer 
// VALUE: 
0,0,0 
// 
//View.Colours.DrawElements.CLR_RULER_TEXT = RGB(0,0,0); 
//-------------------------------------------------------------------- 
// The display colour for the ruler text. 
// UNITS: RGB( 0 to 255, 0 to 255, 0 to 255 ) 
// NUMBER TYPE: integer, integer, integer 
// VALUE: 
0,0,0 
// 
//View.Colours.DrawElements.CLR_LEGEND_TEXT = RGB(0,0,0); 
//-------------------------------------------------------------------- 
// The display colour for the legend text. 
// UNITS: RGB( 0 to 255, 0 to 255, 0 to 255 ) 
// NUMBER TYPE: integer, integer, integer 
// VALUE: 
0,0,0 
// 
//View.Colours.DrawElements.CLR_DET_OUTPUT = RGB(255,255,0); 
//-------------------------------------------------------------------- 
// The display colour for the output detectors. 
// UNITS: RGB( 0 to 255, 0 to 255, 0 to 255 ) 
// NUMBER TYPE: integer, integer, integer 
// VALUE: 
255,255,0 
// 
//View.Colours.DrawElements.CLR_DET_FLOWDENSITY = RGB(0,255,0); 
//-------------------------------------------------------------------- 
// The display colour for the flow-density detectors. 
// UNITS: RGB( 0 to 255, 0 to 255, 0 to 255 ) 
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// NUMBER TYPE: integer, integer, integer 
// VALUE: 
0,255,0 
// 
//View.Colours.DrawElements.CLR_DET_HEADWAY = RGB(0,0,255); 
//-------------------------------------------------------------------- 
// The display colour for the headway detectors. 
// UNITS: RGB( 0 to 255, 0 to 255, 0 to 255 ) 
// NUMBER TYPE: integer, integer, integer 
// VALUE: 
0,0,255 
// 
//View.Colours.DrawElements.CLR_DET_COMPOSITION = RGB(0,0,0); 
//-------------------------------------------------------------------- 
// The display colour for traffic-flow composition detectors. 
// UNITS: RGB( 0 to 255, 0 to 255, 0 to 255 ) 
// NUMBER TYPE: integer, integer, integer 
// VALUE: 
0,0,0 
// 
//View.Colours.DrawElements.CLR_FEAT_SPEEDLIMIT = RGB(255,0,0); 
//-------------------------------------------------------------------- 
// The display colour for the speed limit regions. 
// UNITS: RGB( 0 to 255, 0 to 255, 0 to 255 ) 
// NUMBER TYPE: integer, integer, integer 
// VALUE: 
255,0,0 
// 
//View.Colours.DrawElements.CLR_FEAT_GRADIENT = RGB(0,255,0); 
//-------------------------------------------------------------------- 
// The display colour for the gradient regions. 
// UNITS: RGB( 0 to 255, 0 to 255, 0 to 255 ) 
// NUMBER TYPE: integer, integer, integer 
// VALUE: 
0,255,0 
// 
//View.Colours.DrawElements.CLR_DET_MACRO = RGB(150,150,150); 
//-------------------------------------------------------------------- 
// The display colour for the macroscopic detector regions. 
// UNITS: RGB( 0 to 255, 0 to 255, 0 to 255 ) 
// NUMBER TYPE: integer, integer, integer 
// VALUE: 
150,150,150 
// 
//View.Colours.DrawElements.CLR_DET_MICRO = RGB(150,150,150); 
//-------------------------------------------------------------------- 
// The display colour for the microscopic detector regions. 
// UNITS: RGB( 0 to 255, 0 to 255, 0 to 255 ) 
// NUMBER TYPE: integer, integer, integer 
// VALUE: 
150,150,150 
// 
//View.Colours.DrawElements.CLR_DET_ST_DENSITY = RGB(255,165,0); 
//-------------------------------------------------------------------- 
// The display colour for the microscopic detector regions. 
// UNITS: RGB( 0 to 255, 0 to 255, 0 to 255 ) 
// NUMBER TYPE: integer, integer, integer 
// VALUE: 
255,165,0 
// 
//View.Colours.DrawElements.CLR_DET_ST_SMS = RGB(255,69,0); 
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//-------------------------------------------------------------------- 
// The display colour for the microscopic detector regions. 
// UNITS: RGB( 0 to 255, 0 to 255, 0 to 255 ) 
// NUMBER TYPE: integer, integer, integer 
// VALUE: 
255,69,0 
// 
//View.Legend.DET_LINE_LENGTH = 20; 
//-------------------------------------------------------------------- 
// The detector line length for the legend 
// UNITS: pixels 
// NUMBER TYPE: integer 
// VALUE: 
20 
// 
//View.Legend.VEH_BOX_HEIGHT = 10; 
//-------------------------------------------------------------------- 
// The vehicle box height for the legend 
// UNITS: pixels 
// NUMBER TYPE: integer 
// VALUE: 
10 
// 
//View.Legend.VEH_BOX_WIDTH = 20; 
//-------------------------------------------------------------------- 
// The vehicle box width for the legend 
// UNITS: pixels 
// NUMBER TYPE: integer 
// VALUE: 
20 
// 
//View.Legend.SEG_BOX_HEIGHT = 30; 
//-------------------------------------------------------------------- 
// The segment feature or detector box height for the legend 
// UNITS: pixels 
// NUMBER TYPE: integer 
// VALUE: 
30 
// 
//View.Legend.SEG_BOX_WIDTH = 80; 
//-------------------------------------------------------------------- 
// The segment feature or detector box width for the legend 
// UNITS: pixels 
// NUMBER TYPE: integer 
// VALUE: 
80 
// 
//View.Legend.SYMBOL_TO_TEXT = 20; 
//-------------------------------------------------------------------- 
// The symbol to text distance for the legend 
// UNITS: pixels 
// NUMBER TYPE: integer 
// VALUE: 
20 
// 
//-------------------------------------------------------------------- 
//------------- END OF EVOLVETRAFFIC CONFIGURATION FILE -------------- 
//-------------------------------------------------------------------- 
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